Urgent help - I cannot retrieve my old wallet in MetaMask that is connected to my hardware wallet Trezor T

Dear Trezor team,

I have the Trezor T model which I used together with my MetaMask chrome extension. Since I was having issues with confirming transactions on my Trezor MetaMask account I did the mistake of deleting the MetaMask extension in Google Chrome and then reinstalling it. After the reinstallation all my Metamask account funds, addresses etc. were normal but when clicking on “Connect Hardware Wallet” the Trezor Wallet address with all my funds did not show up.

Since this wallet contains all my savings, I have been meticulous with the seed phrase on MetaMask as well as Trezor suite. Everything was put in exactly the same as before and yet the wallet address just wont show up. I had the “passphrase” setting on in Trezor suite when deleting the MetaMask extension and have tried many times now deactivating it or keeping the passphrase empty or using the correct passphrase and the result is the same, I see many addresses and yet not the one I used before. My previous address will not come up no matter how many addresses I go through.

I have also tried it on several different browsers but also no luck. I took of work this week to fix this issue and went through so many forum posts, videos and solutions that worked for other people, but it just won’t work for me. Would you have any tips on how to solve this? No matter difficult, I am grateful for any help or tips. I also contacted MetaMask but they were of no help, saying that it is a Trezor address issue.

Thank you!

Watch.

I have this problem too. Only I erased my trezor memory and can’t import the correct address in metamask too.

I’m having this problem too, it says DISCONNECTED and I can’t make a transaction or connect. what to do

I have solved the problem. You only get your good adresses see on the Trezor if you put up correcly the 24 words and good PASSPHRASE. I forget to type a capital letter and the adresses are gone.

I would also like to say that I finally managed to solve the issue. The answers of the Trezor team with regards to similar questions are right. I used the right seedphrase but the wrong passphrase. I didn’t pay attention and made a typo when creating the original account which is why it of course never showed up. I tried 20+ different passphrases and eventually the correct address showed up!

1 Like

in the end how do you solve the issue?