Unrecognised Device across multiple OS, cables, ports - all of a sudden?


Filed a support ticked but it submitted before I could fully explain my issue.

I have a Trezor One which has been working great for over a year now. I used it on Friday to sign a transaction.

This afternoon (Monday), I was unable to get my laptop to detect the Trezor. I’m using the same OS, USB port and setup as I have been for a year now so particularly strange. (I’m using Linux and am currently on Pop!_OS, but have had no issues with Fedora 34 and Arch Linux).

Here is what I have tried:

  1. Switch USB Ports
  2. Reinstall Trezor Bridge, Trezor Suite, udev rules for Trezor
  3. Force kill the trezor bridge and run it as a foreground process
  4. Change USB Cables, have tried 3 so far.
  5. Try my old laptop, also running Linux
  6. Tried on a Macbook air with fresh install of Trezor Suite and Bridge
  7. Ran some updates on my laptop (firmware and software)

What’s interesting is that lsusb and other utils aren’t even showing the device as connected/mounted. Light appears on the trezor but no data is being transmitted.

I know that my trezor firmware is not fully up to date, but that hasn’t been an issue in the past.

Would welcome any suggestions on how to proceed.

Hi @JZA,

Could be that your Trezor is malfunctioning. Bad motivator, as they say in Star Wars. :smiley:

Please post your Ticket ID here, so support personel can link your ticket with the additional info in this thread. They’ll take it from there.

1 Like

Hi @Petosiris

ticket ID: 150379

Have also tried in bootloader mode. No joy.

I have similar issues with my Model One. It was working great for years, and suddenly it stopped. The bridge won’t see a connected device, and the device’s screen remains off.

One thing to add is that the last time the device was working, it asked me to provide PIN, and then showed the PIN was incorrect and turned off. Can’t make it work :sweat_smile:

I checked different cables and different laptops. I reinstalled bridge and suite, I reset settings, and restarted software.

My ticket number is: 165397