Trezorctl is not working on Windows

Hello.

I tried installation of trezorctl as described at wiki several times on different Windows 10 (1809) with Python 3.7.4 and latest 3.10.4.

Eventually every time ‘trezorctl’ gives me the error:

Traceback (most recent call last):
File “c:\users\User\appdata\local\programs\python\python37\lib\runpy.py”, line 193, in _run_module_as_main
main”, mod_spec)
File “c:\users\User\appdata\local\programs\python\python37\lib\runpy.py”, line 85, in run_code
exec(code, run_globals)
File "C:\Users\User\AppData\Local\Programs\Python\Python37\Scripts\trezorctl.exe_main
.py", line 5, in
File “c:\users\User\appdata\local\programs\python\python37\lib\site-packages\trezorlib\cli\trezorctl.py”, line 191, in
@cli.resultcallback()
AttributeError: ‘TrezorctlGroup’ object has no attribute ‘resultcallback’

I have no idea as didn’t find solution by searching.
Is version 0.13.0 working on Windows at all? Have tried it on Ubuntu and it was OK.
Please help.

Hi @Mr.Duck

this is a known issue.
more information here: trezorctl: fix Click 8.1 compatibility · Issue #2199 · trezor/trezor-firmware · GitHub

@MichalZ , thank you so much!
“pip uninstall click” and "pip install “click<8.1” makes trezorclt working!
It was not such obvious as simple to fix.
I have wasted several hours to find out the reason.

1 Like