Trezor trying to connecting to known scam address in MetaMask

Hi there,

I have a Trezor with pin and passphrase protect. I’m trying to swap some coins for ETH in Uniswap and when I go to accept the transaction it defaults to a known scam address. I tried a different computer and I still have the same issue, which makes me think I have an issue with my Trezor. I have also tried multiple MM wallets and the same address is appearing. I also wiped my trezor and restored it and I still have the same issue.

Any help would be great.


Hi @jameslv1986,

It’s probably your browser or PC that’s infected with a virus which inserts the scam address instead of the address you enter. So you should do a virus scan and remove any viruses found.

I doubt it’s your Trezor’s fault, but if you want to be sure then you may

  1. Check the validity of your Recovery seed and any Passphrase you use,
  2. Reset Trezor to Factory defaults,
  3. Use your Recovery seed when you set up your Trezor again, to restore your funds,
  4. Update to the latest Firmware, Trezor bridge and Trezor suite.