Trezor T USB not connecting

Hi! i have a trezor model T i didnt used it long time ago, now i tryed to connect to my pc and the device display turning on but there is no “usb device find sound” , the pc didnt see the device so cannot connect.
i try whit another usb c cable at another usb port and in an other cumputer but still the same.
Can someone help for me ?
best regards

Sound? Do you see anything on the device screen?

Yeah the display
is on when i plug in.
but didnt connect and my pc or any pc didnt recognise

when i strat it in bootmode my pc or any pc recognise but not as an usb device , its like com 5 port device, but only in bootmode. i update the firmware but still the same.

What do you see on the device screen? Make sure that the USB cable you use can transfer data and is not simply a charghing cable. Also try to avoid USB hubs and plug to cable directly into the PC. If you use a hub, make sure it’s powered.

does it by any chance say “Locked, tap to unlock” or maybe “Not connected, tap to connect”?
do that first