Trezor T - Invalid Recovery Phrase


I tried to recover my seed phrase because i reset my device.
After putting the correct seed phrase, it always “INVALID RECOVERY PHRASE”

May i know what are the things i will do?

1 Like

I have the same error with TREZOR ONE. What is going on?

hello @ChrisPanen14 and @Mono

Usually this ends up being human error.

Are you talking about the passphrase you created for a hidden wallet for example?


Are you talking about your recovery seed (12words attributed to your wallet)?

If passphrase: there are no wrong passphrases you’re inputing the wrong passphrase and the trezor suite is openning a new wallet for what you consider to be the passphrase.

If recover seed: or you are inputing the wrong set of words or when you wrote them down the where backep up erroneously.

I myself have lost quite a big chunk of my funds because of a wrong passphrase that I wrote down.

Always advisable to check check and double check before sending all your funds to a new wallet.

I have 4 copies of my seedphrase so I can’t be wrong. Also, I have another issue on Ronin trezor account on another post. Would appreciate if you could look at it.

ok @ChrisPanen14

will do.

I had the same issue just now. It’s saying it’s a valid seed phrase but not for this device WTF!