Trezor One Screen Doesn't show anything when enter pin

I use Trezor One. When it’s connected to pc, it ask for entering pin code. But it doesn’t show anything
on the screen, as if the screen is off. It happens either on desktop app or web app. what should I do?

Hi @abc,

Trezor One doesn’t have a touch screen. See the post below for a video of how to enter your PIN:

yeah, I konw. I means Trezor One screen doesn’t show any numbers or preset pic or anything, so I can enter pin code accordingly. In fact, I am aware that Trezor One screen is aways off from the time when I pluged in usb like it’s broken, but my computer says it is connected.

and also my firmware is 1.9.0. Is that because firmware version is too old?

Maybe. Trezor suite should prompt you to update the firmware if it’s too old.

Please try to update Trezor firmware and Trezor suite.
If that doesn’t work better, try another USB cable and make sure it’s a cable that transmits data (not simply a charging cable). Also plug in your USB cable directly into your computer, if you’re using a HUB now.

Eventually, you may have to open a Support ticket for possibly replacing your Trezor with a new one, if it turns out your current Trezor One is defect.

Actually Trezor suite did not prompt me to update the firmware now, but prompt me a few month ago and I ignore it. since I can’t login in the suite, how could I update it now.

I update Trezor One to Firmware 1.11.2, it shows on my computer that update is a success. But the screen is still not lit when I plug in computer, or enter pin code. Can I say that it turns out my current Trezor One is defect?

You have the latest version of firmware for Trezor One then.

Did you try the cable tips?

You can try using the website version of Trezor Suite, here:
To be able to use the web version of Trezor Suite, you should have the latest version of Trezor Bridge.
Too see which version you have installed, if any, see here:
Download Trezor Bridge here:
Note that Trezor Bridge is only needed for the web version. When/if you use the desktop version of Trezor Suite later, it has Bridge installed internally.

Also, please note that if you write several messages after one another, instead of editing the previous message, you’ll soon reach the daily limit for new users, so please press the pencil symbol and edit your messages when you want to post more – if it’s you that also have the previous message. :slight_smile:

All these steps had been tried including changing cables, changing computer, using website version of Trezor Suite by Trezor Bridge version 2.0.27, and still all the same. I thought the screen of Trezor One is broken. I check on google and find a few users have same issues, some ask Trezor for replacement, others fix it by their own means. Do you think in this situation, it has possibly replacing my Trezor with a new one by appliance for Trezor support?

1 Like

Maybe, I don’t know. Since the screen is black it could be your Trezor One must be replaced.