Trezor One Not Turning on ▫

Hello guys just want to ask if somebody has the same experienceright now with my Trezor., just bought in the site then when i recieve it i plug in to my laptop a minutes is good it turn ons but after i download the trezor suites the device suddendly shows error and turned off
i didnt even set up the trezor
question those anyone has the same expirience what should i do
i alread tried to use other laptop and cables

Thanks

Hi @Fernan_Perez

Please, check the suggestions below.

Make sure you are running Trezor Bridge 2.0.27. Check it’s running properly, seek for “trezord” process in your task monitor. Also, check Trezor Bridge Status, available from http://127.0.0.1:21325/status/

If there is no “trezord” process running on the background, and you are getting no results on http://127.0.0.1:21325/status/ , then Trezor Bridge is either not installed or doesn’t run properly. Reinstall it from this source https://wallet.trezor.io/#/bridge . Then, try it again, please (preferably with both supported browsers; Chrome and Firefox in incognito/privacy mode).

Also, please:

  • Clear your browser’s cache.
  • Make sure that you are connecting your Trezor with the cable directly to the computer; please avoid using any USB hub or adapter.
  • Also, please, try connecting your Trezor device to another computer, preferably with a different operating system where Trezor Bridge is installed as well.
  • If you are using a VPN, certain advanced Firewall or Antivirus settings, browser extensions (AdBlock, Privacy Badger, etc.), or some cryptocurrency apps such as Geth or MetaMask, please try to disable them. It is possible that some of these are clashing with Trezor Wallet.
  • If you are running Win 10, 64 bit, install software called Zadig. It is a Windows application that installs generic USB drivers, such as WinUSB, libusb-win32/libusb0.sys or libusbK, to help you access USB devices. Please follow instructions Zadig - Trezor Wiki . After installation, please restart your browser and computer as well.

If you are experiencing issues with Trezor Suite, try using our stable Trezor Wallet https://wallet.trezor.io/#/ instead, and let us know if there is any progress.

hello its not working sir
the device is not turning on when i plug in to the usb port

Maybe it’s shutting down because it’s not set up yet. When it’s new it doesn’t have any firmware installed, so it cannot do much. You should try to set up your Trezor first.

Hello brother i cant set up the trezor it shows in the suite/app “connect trezor”
There’s no power in the device all the cord i tested not working evem blink with the device there’s none😔

What error did you receive the first time, do you remember?

I suspect it may’ve been an error message from the firmware check, which the Trezor does every time it starts. If so, the Trezor you bought had false firmware installed when you received it. It shouldn’t had any firmware then. I think it’s unlikely if you bought it through legit channels. But that doesn’t explain why it won’t even power up now.

It may be a faulty device, of course. In that case you should submit a support ticket and have it returned.

What model of Trezor do you have, and from where did you buy it?

Sir im from Philippines i bought trezor directly to the site so it makes it legit but the thing is its not working no power up
It show some error earlier with device after that it block out and never turn on when i plug in to my laptop this happen after i need to set up to trezor suites i just notice it because it prompt the connect Trezor and when i check its shows error and turned off
I already made some ticket the problem is trezor are no longer catering some order directly here in the Philippines :pensive::pensive: though i need the device badly

Note that Trezor needs a USB cable that can transfer data. Many USB cables can only charge devices, so make sure you use a data cable. Also, retry the original cable that came in the package and see if it powers up. Then try to see what the error message says.

In the picture, it doesn’t look as if the cable is pushed in far enough. Try to reconnect and push until your hear a click. Also try another USB port on your PC.

Hello sir i did it already many times and bought different fast data transfer cable available here still no power :pensive: and also same cable from the box
Maybe its really defective😔 i wish they will refund it through they excluded Philippines from their list.
Thank you sir Petosiris for the help
Have a nice Day
Godbless

Hello @Fernan_Perez

If the display is not lit, it means there is no power in it. Usually, the issue is caused by faulty USB cords, USB ports, or when hubs are used.

However, it can happen that the device might be defective as well.

Anyway, we will check your Ticket and reach out ASAP.

Hello yes thank you i already made a ticket for it im waiting for the response thank you so much
Its hard because im from Philippines and trezor remove our country to their list😔

Hi @Fernan_Perez,

They had to stop the export to the Philippines because your country stopped the import, resulting in many refunds. I don’t know the whole story of why, but here’s the official statement:

don’t worry @Fernan_Perez if your device turn out to by faulty we will issue full refund and you can purchase a new one with official reseller directly in your country :wink:

1 Like

Thank you MichalZ i already send the video of the device and the site where its been tested

1 Like

Thank you Sir i already send the videos to the support team
Hoping for the update,:smiling_face_with_three_hearts:

Hi @Fernan_Perez

Thank you sending the videos. Please, check your inbox for further details.

Hello!I just bought mine a few days ago at first it all went well and when I was writing down the seed phrase it suddenly stop and If I remember correctly it said backup failed and fo to the website trezor i believe and reset it and it turned off…and then when i tried to replug it and solve the problem it doesnt turn on and the day after it turns on and few minutes it will turn off then rhat night I tried to replug it and it worked fine at least for.an hour and I already set uped my wallets and made transactions and after an hour It stopped again and I had to check did all the Zadig stuff but it wont turn on…I need it because my transactions are pending because I already set the back up for a certain game and I cant open it…I’m so tired and exhausted please help thank you…

Hi @Jason_Carlos_Zita

Is your device lit when connected?

Have you checked suggestions mentioned above, https://forum.trezor.io/t/trezor-one-not-turning-on/1845/2?

Lastly, are you able to access bootloader mode and perform factory reset? See instructions for Trezor model One:

  1. Before you plug in Trezor to your computer, hold both buttons pressed
  2. While still holding both buttons pressed, connect Trezor to your computer
  3. Once, you successfully enter bootloader mode, you will see Trezor displaying something like this https://wiki.trezor.io/images/Bootloader.jpg

After you enter bootloader mode, continue to Trezor Wallet from https://wallet.trezor.io/#/ then, you should be given with options to update and to perform factory reset.

Please, let us know how did it go.

Ticket ID: 90713 Sorry for the late reply…I did all what u said and still it won"t connect…I just bought a new one and it runs smoothly now and tried the new cable to my first one and still it won’t turn on…My concern now is can you replace the first one so I can have a back up if ever my trezor gets broken or lost? thank you sir here’s some pictures of my broken one with the box i bought here in South Korea the authorized reseller which is coinzwallet korea…