Trezor Model T, Usb connection, Secure Setup confirmation, and noobs management suggestions

Hi all. I got USB connection problems, but since we common users are not programmers, and we become paranoic and frustrated when things get out of our safe zone of behaviour (as I noticed in most forum complains) I want to write down my experience of setting up my Trezor, see if anyone can get help by reading this, and have confirmation that my Trezor is secured and ready to be used correctly. I won’t send any coin into it until confirmation. I’ll be writing schematically so it should be easier to follow; also pardon me for grammar or wording mistakes, I’m not of English language (luckily).

New Trezor Model T here. Bought from original site (I trust no resellers). Made the error of not buying a quick expedition so i had to wait weeks for expedition to arrive: it was not a time issue for me, but the more I waited the more I feared my package would have been altered or hacked inside common postal services, which level of security should not be the greatest. Fear dooms us common users. Package arrived untampered, holographic sticker all right, usb cable good. I setup the blue gum cover and the Panzer glass. Everything was perfect, no sign of problem.

Windows 7 user. Connected Model T, Windows pop up said Driver not installed. Installed Trezor Suite, then connected Model T as instuctions said. Trezor usb connection not recognised, on any port, with original usb cable. Found official Trezor troubleshooting with Zadig solution (great little program, why I didn’t know earlier?). In Zadig “List All Devices” found a device simply named “TREZOR”, installed libusb-win32 as instructions said, restarted, opened Trezor suite, THEN connected Model T, recognized device. So far problem solved.

Installed firmware 2.5.3 Universal. It said “restarting device” but then device is not recognized anymore. Fuck. Tried everything, even reading forum unuseful complains. Then I reopened Zadig excellent program to check details of USB drivers and devices. Device recognized was TREZOR Interface (Interface 0) with green tick and WinUsb driver installed, not libusb-win32 that i installed before. Is it possible that firmware changed the windows driver? Studied situation a bit, checked infos. After a while of thinking I choosed to set the device that was recognized by Zadig (TREZOR Interface 0, not the hidden one), and reinstall again libusb win32 Disconnected Model T, restart pc, opened Trezor Suite, connected Model T and device went recognized. I think this is the problem I saw often complained: it’s like the firmware changes drivers to WinUSB, then it gets unrecognized again. Probably it’s not Trezor fault, maybe it’s OUR Usb drivers that got some problems we common users don’t know. Maybe SatoshiLabs could improve this by building a better check of usb drivers in the future to help those of us unable to understand these kind of issue.

Trezor Suite said that device has firmware already installed so don’t use it if never used before, but I think it refers to devices shipped with firmware already installed (hacked), so I went through. Set up seed phrase, write down, double check (corrected a word error!!), verify on Trezor. 8 digit pin and check, enabled coins, set up Tor. Only at the end of the process, reviewig my behaviour, I noticed that the main error I made is that I went through the whole process while connected to Internet to find help and infos, so a malicious software could have interfered with the process anytime. It’s unlikely, but as I stated before, when we common users don’t understand what’s going on, we become paranoic. So I disconnected from internet, performed a Factory Reset, restarted pc, performed a scan for malicious software, and repeated the process from scratch. Firmware obviously was already installed so the rest went through easy. I had to disable Tor. When I arrived to coin detection, the coins were already set up like before the wipe: probably this setting is setup into Suite, not into the hardware wallet? It should be stated, since I saw some complais about coins recognition, I also thought obvious it was implemented inside the hardware wallet, but now I undestand it is in the program settings. I suggest it to be clearly explained for us noobs.

I wanted to set a passphrase, SURE that it was like a password for better protection. I always use passphrases for my passwords, they are way more easy to remember while driving to longer and more secure passwords. Luckily I read before, during first time setup, while searching infos, that in Trezor passphrases are TOTALLY NEW WALLETS: I would strongly suggest to change the name “passphrase”, since normally passphrases are better passwords, NOT entirely different things. But if it’s become a techy crypto standard, I will not be listened, no problem. We “normals” are always stages behind the “techs”. If “passphrases” for “new wallets” cannot be changed, I strongly complain to at least put it in full sight when the option of putting a passphrase is shown: THIS IS NOT A PASSWORD-LIKE PROTECTION, THIS CREATES A NEW WALLET. Following the official link for explanation.

Now I ask you if I did it all right and if my Trezor Model T seems secure and ready to receive coins. I’m pretty sure it is but the simple fact of having problems during setup makes our fear drive us mad, so I would like a confirmation. Thanks to you all and best regards for this extraordinary company.

P.s.: Panzer glass is more than a millimeter high, but still touch screen sensitivity is perfect. My standard 9H thin phone glasses never last long. Never heard of that firm though, really worth to check their site. Dear crypto winter, I ask you, Wen IPhone 14? I don’t really like Lambos XDDD