Trezor Model T Standard Wallet ETH account address not found by MetaMask, but does display hidden wallet's account address

Hi,

I set up a new Model T yesterday for purposes on saving some of my more valuable NFTs in a cold wallet.

The wallet has a standard and a hidden wallet, and I sent these NFTs to the standard wallet’s ETH address.

When connecting the Trezor to MetaMask the hidden wallet’s account number is displayed at the top with a tick mark followed by thousands of other account numbers. I gave up having gone through 3 000 account numbers, but no sign of the standard wallet’s ETH address.

Via OpenSea I can see all the NFT tokens that I had transferred to the standard wallet’s ETH address, but at the moment I have no way to access these, should I want to sell any of these down the track.

How do I get MetaMask to “see” or find the standard wallet’s address? I have tried uninstalling and reinstalling the MetaMask extension on Chrome, but I still only see the hidden wallet’s ETH account address and thousand of other accounts. Same result with Firefox.

Thanks in advance for the help!

just leave the passphrase field empty and click the green button when asked for passphrase, that is how you enter standard wallet.

Thanks, is the green button and pass phrase you refer to in a Trezor Suite window, or MetaMask?

the one in metamask, when you are asked for passphrase

Thanks, that did the trick! :raised_hands:t3:

image
just click the Enter