Trezor integration / Ronin Wallet / Axie Infinity

yes I tried, from metamask ETh sent to my trezor, I received it. but for other tokens it never came, its gone.

Hallo everyone,
is there an option for trezor so you need to input your passphrase only once each 30 minutes? I am trying to send a couple of Axies from one Ronin address to an other and it is quite annoying that I need to input the passphrase each and every time I want to initiate a transaction.

I need help with my trezor, After updating my trezor device this morning it wasn’t able to connect with my hidden wallets, It’s giving me a different address from ronin wallet when exporting new accounts from trezor.


  1. Reset my PC
  2. reformat my trezor

I’m sure that my password is correct since I’m actively using it for 1 year for my axie scholars. In fact, I just transferred some axies to them yesterday to test a new build for them. Then suddenly there was an update this morning and after that update, I can’t access my account anymore.

We’re an active guild, Please I need to fix this asap.


please see the posts above:
TLDR if you are using the same combination of seed and passphrase you will always enter the same wallet as all accounts and addresses are derived from the combination of those two inputs.

So in other words updating firmware could not affect wallet derivation process. If you think it could then downgrading the firmware would be able to resolve your issue (which will not, you can try).

Thus the only way how to get to the same list of addresses is to use exactly the same combination of seed ans passphrase as you did in the first place.

I tried this as well, Downgraded the firmware but did not work. after formatting my trezor I got these 2 accounts. I don’t know if this is normal. I’m only using 1 seed phrase and my passphrase is not related to my seed phrase. But I can clearly remember it since I’m already using it for a year. I don’t think I’ll forget this passphrase since it’s my password for my other accounts. As I said in my post, I’m actively using this passphrase to transfer axies for my scholars since we’re testing out builds for origin.


2 posts were split to a new topic: Other languages - Trezor integration / Ronin Wallet / Axie Infinity

Can you please help me. I log in my ronin using my trezor and when i paired the trezor to my ronin theres no confirmation that will open my ronin. its kinda bad im new to trezor

I have just associated my new trezor account to my Ronin account and transferred some AXS and RON.

At the moment both tokens are stuck in my trezor account - cannot swap, transfer or stake.
Apparently, I did not create a new Axie marketplace for this new Trezor account.

Any tips on how to unblock this one?

Update to my previously stated problem with more details, really appreciate your help!

I added a new Trezor address/account to my previously existing Ronin wallet.
I transferred AXS and RON from my original Ronin address to the newly created Trezor address.
Unfortunately, I would not be able to make any operation with the Trezor address.
Later I read that a new Axie marketplace account needs to be created every time a new address is added, and always before transferring tokens.
The market place would not allow me to create an account for this new address.
After multiple attempts, I was able to somehow create the account and stake my AXS.

At the moment, the same problem is back: cannot perform any operation with my Ronin Trezor account.

Any leads?


I wanted to report the issue that I am having with my Trezor Wallet. The SLPs that I earned from Axie Infinity were missing after a firmware update happened. I moved my SLPs from other accounts to consolidate them in one wallet, the SLPs were successfully moved, and seen them in my Trezor Wallet for how many days, however, after a firmware update my SLPs were missing and can’t be found in any of my wallets. I checked if there were activities that my crypto was moved but there were none. Can you help me with this issue and retrieve my SLP?

hi, @pheejhay10

What interface do you refer to? or Trezor Suite or 3rd party wallet ?
Please note that if you don’t see any transaction history nor the address/account in question, then you are accessing different wallet (most probably because you are entering different passphrase).

Please see following topics as this issue has been already discussed here sooo many times:

Alternatively your device could have been wiped after failed firmware update.
More in following post:

Sorry, I forgot to mention that I am referring to a Ronin Wallet. I moved my SLP to a Ronin Wallet that is inside my Trezor Wallet, I have successfully moved them inside my Ronin Wallet and then few days back I am no longer seeing them.

I am quite sure though that I am checking in the right Ronin Wallet where I moved my SLP.

I have tried this method, but this seem to refer that the recovery process is done via the Trezor Suite, but the SLPs that are missing is in my Ronin Wallet. It does seem it is a different process for Ronin.

If your SLPs are in the Ronin account linked to your hardware wallet wiping the device would matter as you’d delete all data related to the addresses derived from your Trezor private key.

Anyway, do you see any transaction history (under bookmark activities) in the Ronin account linked to your Trezor ? Is the address of this account same as the one where you previously sent your assets to ?

By wiping my account, did you mean resetting my wallet?

There was no transaction that happened in my Ronin wallet except for buying, selling, and moving Axies. And yes it is the same Ronin address that I used to move my SLPs.

Wipe feature enables you to delete all data associated with the pre-existing accounts, and settings associated with the device, such as the PIN, name, homescreen, and passphrase settings.

Then there is also factory reset that erase the firmware as well however that doesn’t matter that much as you would in both cases be able to recover your wallet with mnemonic phrase.

So do you see any transaction history (deposits) now?
Is the address of this Ronin/Trezor account same as the one where you previously sent your assets to ?

I do not see the deposit transactions to my Ronin/Trezor account, I think only transactions that were bought/sold/and moved from the accounts are what is being recorded (not fully sure, but that’s what I observed in the recorded transaction).

But I did see that the transactions were recorded from my old Ronin Wallet where the SLP came from and it is the same Ronin/Trezor wallet I used to transfer my assets. So, to answer the 2nd question it is the same address/account to where I previously sent my assets.

I also moved new assets to the same address the other day, and those assets are still there today just the ones I sent more than a week back are the ones I cannot see.

I see, thank you for our answers.

I will send you PM (for privacy reasons), could you please answer it and provide TxID of the transaction you mentioned and also the address in question ? thx

hi i bought a trezor to use for my axie infinity game
i created a ronin account and connect it to the trezor hardware wallet.

after creating it successfully, i cant transact.
the ronin account i created is not showing on the trezor list of accounts

there is a list of 50 accounts to import but the account i created is not on the list

hope that someone can help.


hi @Jhon

your are using either different seed or different passphrase:

1 Like