Trezor Check Backup


When I’m trying to check the Seedphrase that I wrote down, there’s this one-word “snug” which I can’t seem to type in the trezor hardware itself. It automatically completes a different word whenever I try to type in. Any solutions for this?

Hi, there is no such word on the list of possible words, so you have recorded wrong word unfortunately.

You can try similar words starting with “sn”


That’s what I don’t understand because before I was able to type it in and some words appear on the trezor itself which is not on the list you shared. an example is snapshot.

ok, snapshot is on the list of words for shamir backup: slips/wordlist.txt at master · satoshilabs/slips · GitHub

So you created advanced backup, which means that during check you have to select 20 words.

However snug is not on either list.

I’m having this problem but with the word “zone” which is on the list. I tried to move forward with “tone” in case I copied it down wrong but that doesn’t work either.

and what exactly is the problem? If it is wrong then try other similar words (ozone, stone)

I reviewed my words 3 times so I don’t think I have the wrong word. When I try to check my backup and I get to this word, I select T-Z and in the next screen it removes all Z options and I can’t proceed to even try to spell zone which is a seed word.

yes, because you selected T as your first letter…if you want to spell Z first then press the correct tile


My screen doesn’t give me those options. It only gives me the option of T-Z.

I’ll add that I have been able to successfully input 23 out of 24 seed words. It’s just this word that is giving me trouble.

have you tried standard recovery instead of Advanced?


select T-Z


select WI-Z


select Z


there you have it!


That worked, thank you very much!