Trezor Bridge not working with adalite and theta wallet

https://connect.trezor.io/8/popup.html#
When trying to connect my Trezor on my MAC to adalite and theta web sites, both sites redirect to web site able and I get a continuous spinning loading symbol.
Any ideas? I did clear the firefox cache and reinstall the latest trezor bridge just now.
Thanks

Hi @Moury,

make sure your Firefox browser is up to date. Also, try to connect to Theta and Adalite via Chrome browser.

Do you see “trezord” process running on your system? You can verify it with Task Manager (Activity Monitor if you are using macOS).
Are able to open Trezor Bridge Status page?

Hey you were right, even though Firefox is up to date, the Trezor Bridge is installed and verifiable in Firefox, only Chrome could complete the connection. Any idea why this stopped working recently in Firefox? Maybe the latest Trezor Firmware / Firefox plug in is not up to date or buggy?
We really prefer Firefox over Chrome - Personal Reasons. Let me know if you or Trezor can test the Firefox connection with Theta and AdaLite with latest Trezor T firmware moving forward.

I use Trezor device (old device, Trezor 1) to manage Theta and Stellar Lumen wallets. I have not accessed these two wallets for a while and am not sure when the problem occurred, I noticed it today.

In the past, I used Firefox browser to access Theta and Stellar Account Viewer wallets.

I now cannot open neither of these two wallets using my Trezor, once I click on Connect Trezor, it takes me to “connect-trezor-io-8-popup” (I changed all dots and forward slashes, as I cannot post links), where it shows Trezor connect site but it does not connect, it just keep spinning.

I saw today on your forum that another user recently reported the same issue regarding Theta wallet and your advice was to try to do it via Google Chrome browser, that is why I am replying to your response

I have tried using Google Chrome browser as well and it displays warning message that I need to update/download trezor bridge (I did not even reach this stage when I tried it in Firefox)

I have subsequently downloaded trezor bridge 2.0.27, restarted the PC and tried via Chrome again, but the same message keeps coming up as given above, asking me to update/download the trezor bridge.

I checked my Task Manager, “trezord” process is running on my system when I plug in my Trezor device.

When I check the Trezor bridge status, it shows 1 connected device but no session?

I am not able to uninstall trezor bridge and install it again, as it is not shown on my Uninstall Programs list

I do not know what to do next, as I still cannot connect my Trezor to Theta wallet. I have updated both Firefox and Chrome browsers and it did not help

I have the same problem with Stellar Account Vivewer wallet, the same happens as described above for Theta wallet.

I hope you would be able to provide some guidance as to what to do to resolve my problems with these wallets

Thanks

V

Hi @UserXXX,

try to clear the cache in your Chrome browser. If the issue still persists, try to reinstall the Chrome browser.

Thanks, clearing cache did not help.

I don’t want to uninstall Chrome, since i have multiple Chrome extensions installed for various wallets.
Is there another way to get it working? Why did it stop working with Firefox in the first place?

Also, try to connect to Theta wallet and Account Viewer also in “incognito mode” (New Incognito Window). If the issue persists in incognito mode, try to reinstall Trezor Bridge. If you have Windows, you need to find the folder with Trezor Bridge first (C:\Program Files (x86)\TREZOR Bridge). You can uninstall it with “Uninstall.exe”.

After you uninstall Trezor Bridge, check if you can still see the process “trezord.exe” in your activity monitor. It shouldn’t be there, if it is there, please kill the process. Try connecting to the Theta wallet and Account Viewer once again. Without Trezor Bridge Chrome will use its own bundled communication protocol WebUSB and you should be able to connect to 3rd party wallets successfully.

Thanks, I will check it all tomorrow and let you know if still having issues.

Regards

Hi,

nothing you suggested worked on computer I am currently using. I then tried it on an old laptop, where I did not use Chrome at all, it worked on it, after I installed Google Chrome.

Will it be fixed for Firefox? As few other people said, I also do not like using Chrome unless I absolutely have to.

Thanks for your help