Touch screen issue

Hi, my touch screen is not functioning on my trezor T and cant get to do anything with it. now I have 2 problems.
1st is how am i supposed to wipe this wallet if i can’t confirm anything?
2nd is I bought a trezor 1 to for backup but i used shamir backup is there any way i can use it?
thank you

Hi @queso,

About #1 - Please submit a Ticket to customer support, using this form, and post your Ticket ID here so your issue can be linked to this thread.

About #2 - The backup device must be set up exactly as the original, with the same private seed and accounts, plus any Hidden wallets with Passphrase you may have. Note that a Trezor Model One cannot serve fully as a backup to Model T, as Model One doesn’t support all the coins & tokens that Model T does and the Firmware may differ too. If I were you, I’d use a Model T as a backup device.

1 Like

Just to make it clear, Shamir backup feature is available on Trezor Model T only. Learn more

Today my new Model T arrived - I was very happy, until i tried to setup everything.

The Touchscreen is not responding like in this Post ( New Trezor-T; Non-Functioning Touchscreen )
I have the same Problem seen in this 2 year old Video from Reddit:

My touchscreen is not responding at all, so i cant even confirm making a new wallet (rejecting does not work eighter ;))

Can somebody from the supportteam get in contact with me please? I bought from Trezor -Shop website and not through third party retail.

Ticket ID: 104565

Firmware: 2.4.2
Transport: Bridge 2.0.31

Thank you very much in advance for a fast response.

:slightly_frowning_face: :frowning_face: :crying_cat_face:

Dear Support,

With reference Ticket ID: 102982.
I received the item yesterday and I have issues with the touch screen. There is no touch response on the right bottom of the screen, which is frustrating because it is where the OK/Accept icon is always located.

As of now, it is not fully working (see attached video) and I cannot use my wallet.

Main Video Link (via Dropbox):
Alternate Video Link (via YouTube): Touchscreen not working properly on Brand New Trezor T - YouTube

Please advise.


Michael Cadungog

Simmilar problem here - cant even go beyond the setup process because touchscreen is not working at all

I too was very excited. My touch screen doesn’t respond either. I was like, WTF, are there other buttons?
Even the Support search had nothing under ‘touch screen’. I’m looking to see what other wallets are out there…image having $20,000 of crypto on the Trezor Model T. Whew, I guess it is better to know now, than later. $200 down the drain.

I tried my brand new trezor model T today too 165 EUR down the drain. Support said i should have an answer in 14 days. SatoshiLabs Group ticket created - Model T Touch screen doesn’t work - Ticket ID: 107853