I have purchased THETA and TFUEL on an exchange and now trying to withdraw and store it on my Trezor Model T. (I have already successfully withdrawn Bitcoin, so I’m familiar with getting major cryptos into the Trezor).

Per the Trezor website, it says I can use MyCrypto wallet or MyEtherWallet for THETA and TFUEL. I’ve taken a look at both. However, I’m still a bit lost in how to get started.

How do I get a proper THETA and TFUEL address and have the Trezor recognize it? (From directly within the Trezor, there is no THETA or TFUEL option). I understand the general concepts, but the first time execution is still a bit unclear to me.

Thank you for your support/suggestions.

Hi @token4theppl,

I can confirm you can use THETA and TFUEL with your Trezor device. However, Theta is not natively supported in Trezor Suite, to access Theta address, you need to use Theta official wallet at Since they integrated Trezor as well, you can simply connect your Trezor device with Theta Wallet (select “Hardware” tab > “Trezor” > export public keys > select desired address).

Please keep in mind that you need Trezor Bridge installed on your computer. Also, make sure to use supported browsers (Chrome and Firefox).

Hi @radekP ,

Thanks for your clear explanation.

Unfortunately, when I try to connect my Trezor via the webpage you listed (select Trezor, then Connect), it just hangs indefinitely. I’ve confirmed that I have Trezor Bridge installed (I can also see trezord.exe running via Task Manager) and I’m also using Firefox. I can also confirm that Trezor Suite loads the device without issue.

The only other note of context I can share (that may or may not have had an impact), is that, prior to this entire thread, I was trying various things to get a small portion of the THETA/TFUEL off the exchange. In my frustration and impatience, I selected (via Trezor Suite) my Ethereum address and had the exchange send a small amount of THETA to it. The exchange said it was successful, but obviously in Trezor Suite there is no THETA (nor Ethereum). Could I have accidentally corrupted the hardware wallet to where THETA wallet (web address you provided) cannot connect at all?

I’m at a loss and just want to get my THETA off the exchange and in my own possession.

What do you recommend I try?


Hi @radekP ,

Just to add notes for an addition thing I tried.

I updated my firmware (from 2.5.1 to 2.5.2)

I completely wiped out my Trezor Model T device and recovered it from my Shamir backup/recovery seeds.

I tried everything again as per your instructions and, still, the THETA wallet cannot connect to the device. (I’ve confirmed several attempts and tries, reboots to clear all caches, etc … and still nothing).

Eagerly awaiting your recommendations on a path forward.

Thank you

UPDATE: Firebox is currently NOT working well with THETA wallet.

I was able to connect to the Model T using Chrome. I also saw on another message forum a user having a similar problem with Firefox and was able to use Edge.

One question for clarification:

Based on this, am I correct in understanding that the Trezor is storing the public and private keys for the THETA wallet, however, you cannot do transactions directly from the Trezor (TrezorSuite for example) and must perform transactions on the THETA wallet (or other 3rd party wallet)?

Is this correct?


Theta Wallet uses the same format of address as ETH. After you connect your Trezor to Theta Wallet, select the address you used as receiving address for your transaction from the exchange and you will be able to see and manage this small portion of the THETA/TFUEL you sent there.

Edge is not officially supported, I can recommend using Chrome if the connection doesn’t work in Firefox.

You are correct. Trezor device stores public and private keys and you can use these via 3rd party app (Theta Wallet) as Trezor Suite doesn’t natively support this coin.


Thank you @radekP for your excellent support!!