Sign transaction error: Passphrase is incorrect

I recently purchased the Trezor Model T. I used the desktop suite to send BTC to the standard wallet. Then I created a hidden wallet and I transferred most of the BTC to the hidden wallet. These are the only transactions I have ever made on my Trezor. Now I want to send all of my funds from my Trezor to a another external wallet.

When I try to send BTC from the hidden wallet to another wallet using the desktop suite, it prompts me for my passphrase. When I hit “Review & Send” and enter my passphrase, I continue to get the message: “Sign transaction error: Passphrase is incorrect”.

I tried using the web browser suite on Chrome browser and when I enter the passphrase to unlock the hidden wallet, I get the following message: “This hidden wallet is empty. To make sure you are in the correct hidden wallet, please type again the passphrase on Trezor.” Could this also indicate that the passphrase is incorrect, or does it indicate that the passphrase is correct and that it is empty?

Then I tried using the web browser suite with Firefox. After entering the passphrase, no messages are displayed and no hidden wallet is displayed. Also, the standard wallet is shown with a 0 BTC balance. However, on Chrome the standard wallet balance is correct.

On the desktop suite I can view the standard wallet and hidden wallet just fine, including the balance of the hidden wallet. I just can’t send funds from the hidden wallet. I wonder if I were to eject the hidden wallet, would I be able to add the hidden wallet again? Or would the desktop suite also indicate that my passphrase is incorrect? I’m afraid to try this.

I know for certain that I am entering the correct passphrase. It is very simple, carefully entered, and I just recently created it. I’m new to Trezor and learning how to use it, but I can not believe that my passphrase is wrong. Is there any other explanation? Is there anything I can do to send my BTC from the hidden account?

Also, why does my standard wallet balance have different balances displayed depending upon which browser or suite I use to view it?

Ok. I’d advice you to use Trezor Suite then, because it’s in active development and has more functions than the website wallets ( and, plus you won’t get the many potential problems as in a web browser. The web wallets will eventually be replaced entirely by Trezor Suite, but they’re still operational for solving special cases.

Yes, you can eject the Hidden wallet and reopen (not add) it anytime, with your Passphrase. I do this all the time myself, when I switch between my Standard wallet and the Hidden wallet. Note that this requires you to remember and use the correct Passphrase.

There could be several reasons, for instance that the browser has cached your session. So you should always clear the browser cache when you use Trezor with a web wallet. But it’s hard to say exact what could be the issue in your case. As I said above, if you use Trezor Suite you can avoid such things that can occur when you use a browser with Trezor.

If you mistype your Passphrase, it’ll create a new and empty Hidden wallet. Note that your Passphrase must be exactly as you created it. Large and small characters are different and space is also a character.


Passphrase created for Hidden wallet is “Vanilla and Chocolate Ice Cream”

If you later try to open your Hidden wallet and type “vanilla and chocolate ice cream”, then a new and empty Hidden wallet will be created instead of opening the original.

Same result if you type “Vanilla and Chocolate IceCream”.

About signing transactions, you should try updating to the new Trezor Suite, released today, October 13. It has a new function for signing and may also have fixes you need in your case. To update Trezor Suite for desktop, just start it and it’ll prompt you to download an install the newest version.

No, there’s no other explanation. If you enter the correct Passphrase, your original Hidden wallet be opened every time, without exception.

Thank you for your reply.

I did update to the new Trezor Suite today on my MacBook before attempting to send BTC.

I received my Trezor about one month ago and used the Trezor Suite app. I created a hidden wallet. I made a very short, simple, common, all lowercase, one-word passphrase. Despite being easily memorized, I also wrote down the passphrase. I transferred 0.3399 BTC to the wallet.

Now, as far as I can tell, that same passphrase is rejected by Trezor Suite when I attempt to send BTC from my hidden wallet. I have only ever used the Trezor device to enter the passphrase, never using my laptop keyboard to type the passphrase. It is the only passphrase I’ve ever used. The pattern of entering the passphrase letters onto the small device is still familiar to me from when I created the passphrase a month ago. I believe the passphrase creation process included entering the passphrase twice. Plus, I successfully used that passphrase at least a couple times after creating it. I don’t understand how I could have screwed it up, but I also tried entering every possible typo that I can think of with no luck.

It is difficult to believe my passphrase is wrong, but I understand there is no other explanation. It looks like I’ve lost all of my BTC.

I tried entering my one-word passphrase with my keyboard instead of with the Trezor device. I capitalized the first letter of the word. The passphrase was accepted and I was able to send my BTC.

I don’t see how it is possible to enter capital/large letters on the Trezor device, but I know I used the device to repeatedly and successfully entered the passphrase a month ago. I ejected the hidden wallet. Then I was able to unlock the hidden wallet again using only lower case/small letters on my Trezor device.

I must have initially created the passphrase on my keyboard using a capital letter. Later, the hidden wallet can be unlocked using only lower-case letters for passphrase entry on the Trezor device. However, BTC can NOT be sent using only lower-case letters for passphrase entry on the Trezor device. Sending BTC can only be done successfully using the keyboard to enter a captial letter. This is an important difference to note between unlocking the hidden wallet and sending BTC!

I’m so relieved. Thanks for your help.

One more question: is there a way to enter capital/large letters on the Trezor device?

1 Like

That sounds strange and non-intuitive. I had no idea it was as you say here. Perhaps @pavel, @kolin or Developer @matejcik has an explanation?

This issue may certainly be the reason many other people have problems using Passphrase too.


No problem. I’m glad you solved it in the end. :+1:

I honestly don’t know. Perhaps I shouldn’t reveal this … but I’ve never typed the Passphrase on my Trezor, only used the keyboard on my PC, so I don’t know how this function looks on the device. Perhaps if you press & hold a character, it’ll be capitalized?

Press and hold also results in lower-case letters. I’ve tried taps, holds, and swipes. I haven’t yet been able to create any passphrase capital letters on the Trezor device.

Ok, noted. I’ll try this myself later and see how it works. In the meantime we’ll both just have to wait until the experts can shed some light on this. Please come back later when they’ve replied.

Swiping left or right on the passphrase keyboard opens more keyboard variants: upper-case, lower-case, numbers, and special characters.

I believe that you must have done this at first, and then at some point forgot about it.

The hidden wallet cannot be unlocked by a wrong passphrase.
(and yes, difference of upper/lower case counts as different passphrase)

However, if you have the hidden wallet “remembered” via the toggle in Suite, you don’t actually need to unlock it to see the balance and history. You would only need to enter the correct passphrase to send, or to show receiving address on Trezor screen.

1 Like