Send max button in Suite doesn't wotk with cardano

The “send max” button hasn’t been working for several months for me alrteady while sending cardano transactions.
Filling in the value manually works.
Can you fix it?

I have just tested it and it is working just fine:

What is the version of Trezor Suite you are using ?

Also, I have noticed on the screenshot that you are sending to eight different recipients at once. Please make sure that you still have enough funds after filling up the amount for those previous seven otherwise you will end up with not enough funds as shown on the pic below:

For me it doesn’t work. I tried it with a single recipient for simplicity and it didn’t wotk either. I also tried it with both addr1 and A addresses. See the two attached screenshots.
I use suite 23.2.1 on windows.

could you please open a ticket via the speech bubble in the left down corner at: and send me your ticket ID here in the chat ?

We will continue troubleshooting the issue in the private channel as some sensitive info will be required (xpub, app log).