Screen blurred out


I logged in to my wallet. The screen is blurred out and I cannot see information. It says backend is disconnected and looks like it is trying to connect. I am a little worried on this. How can this be fixed?

Also, when i clicked on the link to download the firmware to get to the latest version, it said to have my passphrase. I saw that as a red flag.


Hi @dvcastro33,

Your discreet mode is enabled, you can disable it with “eye” icon in the top right corner of Trezor Suite:

Screenshot 2022-10-25 at 9.13.20

Try to reset the Trezor Suite. You can reset Trezor Suite in “Settings” (gearwheel symbol in the top right part of Trezor Suite). Navigate to the “Application” tab and select “Reset app”.

Remember, you will need to enable all desired cryptocurrency accounts after resetting. It can also be done in “Settings”, this time you need to navigate to “Crypto” tab and select all desired coins.

Most likely it asked you if you have recovery seed before you start firmware update. In general, the seed should not be required during the firmware update; however, there might be an issue (connection is lost, etc.) and then the device can get wiped and all user data erased. This is a security feature, in fact, that protects your assets against an attack, for example, one that would try to install unofficial firmware on your device. This is why you are always asked if you have your recovery seed before you start firmware update.

1 Like

Thank you radekP. I tried to get in to my hidden wallet. However, it says “This hidden wallet is empty. To make sure you are in the correct hidden wallet, please type the passphrase again”. I did that and it says the back end is down. I tried to reset the app but it is not working. Do you have any suggestions? I see on etherscan my tokens are still there, but it says my wallet is empty.

I was able to fix it. Took some time. I had to reset to factory settings and use my recovery seed to reset. I still had the issue. Looked online in this forum and saw that I should have TOR enabled. I never even knew about this and after I enabled it, I see my tokens.

1 Like