Ronin hardware wallet not showing valid address in marketplace (Axie Infinity)

I have completed the Trezor T setup, I have main Ronin wallet and recently connected hardware wallet that created sub accounts in my Ronin. However when I try to send axie to this ronin address I get an error message - “The address is not in our MarketPlace, make sure its the right one”. This ronin address is correct and it was created using Trezor T wallet. Do I need to do something to have it recognized by the marketplace as an active and valid ronin address?
The first hardware account is okay, but the rest are getting the same error

Thank you

Hi @dalefortoday,

Please see guide videos here:

1 Like

Did you create new axie accounts with the trezor sub-accounts?

Hi were you able to access your axies eventually? I think same thing happened to me just now. The trezor wallet cannot be seen in Axie marketplace

And you created actual Axie Infinity accounts using the Connected Ronin Trezor Hardware account?

Hello @Langly1087 i need your help. I cannot login ronin to marketplace using my trezor. I already wipe and recover using my seedphrase, but why its still the same? And no binary code show up on my trezor device. Please help me. I am so desperate.

1 Like

Hey there Ann,
sorry for the slow reply. I have Covid right now and the Brain Fog is killer right now.

That said, after connecting your trezor wallet to the Ronin, did you log in with that Ronin Trezor account to create an Axie Infinity Account? Or did you send Axies to the account before creating an Axie Infinity account?

Hi, @Langly1087 I send axies to ronin connected to trezor before creating account to marketplace. And now, i don’t know what to do. :frowning: i am stuck here for 5 days. Please help me. @Langly1087

@Langly1087 getwell. Praying for you. :relaxed:

@Langly1087 hi there.i have one last question.

If ever i forgot my passphrase will i have a chance to recover it?

Thanks in advance.

1 Like

Hi @Ann

Under no circumstances, you must not forget your passphrase. There is no way to recover it.

Learn about passphrase, and make sure you fully understand this feature before starting using it.

That would be a negative. That’s why it is recommended to write the passphrase down on a piece of paper as a hard copy to never be lost.

“This address is not in our Marketplace, make sure it’s the right one.”

This is the message I get when I wanted to transfer an axie to a newly made account from my hardwallet.
How do I solve this?
tbh Trezor can be so irritating at times.

Did you create an axie infinity account with the new account?

Hi! Yes I did,
And I figured out my mistake! It was not an issue with the Trezor as I first assumed - It was the fact that:

I have not yet set up my Email and password on the Axie infinity site yet. Sure the wallet exists, but the email has not been set up properly yet.

Also, it is still possible to send the Axie, even if this warning sign showed up.

Also thank you @Langly1087 for the videos - lifesaver.


Great! Happy to hear you found a solution! :slight_smile:

Hi Ann. I have the same problem as well. The axie infinity support is absolutely unhelful, it’s been 7 days now and still nothing from them. May I know if you found any solution from this issue? I would be very grateful for any help.Thanks.


Greetings, @Langly1087 , hope everything is well with you mate. I have the same problem with Ann, I sent axies, slp and weth to my new Ronin Trezor account without first creating an actual Axie Infinity account. Now, I’m stuck and cannot send my assets back to my previous Ronin accounts and everytime I tried to login, its just blank, nothing. Any solution with this kind of issue? Any help would be appreciated. Thanks.

Kind regards,

1 Like

Unfortunately, there is no solution for this at the moment. It’s a bug with the Ronin wallet that they need to get fixed. I’ve been recommending that people flood the sky mavis support ticket system with this issue. Hopefully they will get it fixed soon.

1 Like

Try to put email & password then send out your assets.