Required To Install Firmware Now Crypto Is Gone

The Trezor is now my nightmare.

I installed a necessary firmware to Trezor.

Then I was trying to set up recovery but the seed didn’t work (yes I done my seed twice and double checked it and tested it and it worked but not this time after multiple times, I really did believe it or not)
Then I set up new wallet and boom all my crypto is gone.
How to I get back to my previous account.
Top this off with never receiving my Eth after 24 hrs.
Please someone tell me I can recover my crypto?

Hi @Dunner

Please see this post:

And come back to us when necessary.

Yes everything is fine but I didn’t get my Ethereum back?

This is weird.

The address history is this address : 0xEec4a89199d96Ba7cBE23272747a97781184ac64

And 5 other addresses. This is obviously Trezors and Ethereums fault.
Do you know Trezor have no safety notice at all during a transaction???
Do you know how many people have forever lost crypto due to sending BTC to BTC Cash or Eth to Eth Classic. BTC will twindle away slowly due to these massive design flaws. Trezor you are hopeless and wish I never got one.

But the original address is this:


Hi again,


When the same seed (and the same passphrase) is used the same wallets, accounts, and addresses are generated no matter what app is used. It’s based on a public-key cryptography.

Double check the following:

Pair your Trezor device with any compatible app, such as MEW, MyCrypto, Trezor Suite etc. If you cannot see the address of yours, then you either used a different seed or a different passphrase.

Have you been using passphrase? If so, make sure you fully understand how passphrase works .

TL;DR the only solution is to use the correct combination of seed (and passphrase).

Before any transaction is made, it must be signed by private keys stored on Trezor device. User manual:Making payments - Trezor Wiki

True. However, it’s not Trezor fault that both forks (BTC Cash fork and ETH) decided to follow the same address format (or a similar one) as they predecessors (BTC and ETH Classic).

No its done. I sent the correct address but on wrong account. I 5x check my address and even then I take a glance. My Etheruem got stuck on the Classic Eth track. It took me 2 or 3 hours to work out the technicals and fiddling around with it but it worked out.

Honestly thats not good, your Etheruem not showing up and thankfully I’m minimal at tech but it was enough to get me out of the hole. but if your not tech minded, good luck ha. Your crypto is gonna sit there in the crypto no mans land.

If this is your case

Then, this is the solution