Rentering passphrase for each transaction

Hello,

Lately my Trezor Model T has been requiring me to reenter my passphrase for each transaction. In the latest case I wanted to send 3 Ethereum transactions in a row via metamask for the same wallet and each time it made me enter my passphrase. This makes using it much more tedious and I don’t understand why it works this way now when it used to not require me to do this.

I fully understand and whole heartedly agree with entering the passphrase each time you plug in the device, but once you enter the passphrase for a given wallet you should be able to send subsequent transactions for that same wallet without rentering your passphrase each time.

My firmware is up to date (v2.4.3)

If you don’t use a hidden wallet, then you don’t need to enter a passphrase when transacting.

Yes I am aware of this but I am opting to use a passphrase for the extra security it provides.

The private key of the hidden wallet is jointly generated by the seed phrase and passphrase, and the private key verification is required every time a transaction is signed. Trezor also removes the memory of previously entered passphrases for extra security.

OK so this is a recent change to how the trezor works? Because it definitely did not used to work this way. Is there a setting to change it back to the previous functionality? I am all for extra security but this is a step way too far and is simply annoying.

It seems that this change cannot be reversed. Or you can ask forum support.

Can you direct me to the proper support forum? I’m new here and do not see a support category. Thanks.

I found this form and submitted my inquiry there. Is this the correct way to go about this?

https://trezor.io/support/general/question/

image
People with a shield pattern after their name and the word community support.
You can find them and reply to them directly.

1 Like

Under normal operation, you should only enter the passphrase once per “session”, where one “session” is vaguely “from opening the hidden wallet in Suite, until closing Suite”.

It is possible that a bug in either Connect or Metamask is shutting down sessions sooner than it should, e.g., after every transaction.

However, I can’t reproduce the problem you are seeing. Is it possible that something has changed in your browser? (3rd party cookie configuration or similar)

OK I’ll do some testing on multiple browsers/computers and see if there is some sort of issue on my end. Typically the only time I need to do subsequent transactions for the same wallet is with metamask, not trezor suite. Thanks for the info.

I tried submitting back to back transactions on a different computer and did not run into this problem, so there is clearly some issue affecting my primary computer and/or browser. I’ll work on troubleshooting but I am definitely relieved that this was not the result of a design change. Thank you @BtcLtc and @matejcik for your assistance.

1 Like

I’m having this exact same problem in two different browsers. How did you fix it?

I’m having the same problem in Chrome and Brave since I reset the PC. I tried resetting it again and still have the same issue.

Sometimes, after confirming on Metamask, the Trezor windows says: " Passphrase doesn’t match. Looks like You have set a different passphrase".

Other times, after confirming on Metamask, the Trezor window just keeps on endlessly loading and I have to restart the browser.

This is a total mess, unusable since I reset the PC.

I was never able to figure out a fix and have tried multiple browsers as well. Usually after a fresh restart it will work properly but eventually it will revert to making me enter the passphrase for ever single transaction.

I also sometimes get the “Passphrase doesn’t match.” problem even though I’m certain I entered the passphrase correctly and even after I carefully try again I will get the same message. In these cases I have to disconnect and reconnect the trezor to get it to accept the passphrase. It is a total mess and I’ve given up on trying to figure out a fix. Once the gridplus lattice is back in stock this month I’m going to pick one up.