Problems with Yoroi and Trezor

I have successfully connected Trezor to Yoroi in my PC. It was working fine. I have staked sent transactions. Everything is normal.

At one point, I have managed to buy myself a crypto laptop (a Macbook Air). I wanted to migrate everything from there, Metamask, Ronin, Yoroi, etc.

Metamask and Ronin migration was fine. But when I tried to configure Trezor with my Yoroi in my Macbook it’s showing this error.

I have removed the wallet in Yoroi in my PC likewise the extension. I don’t know what I’m supposed to do.

I just want to access Yoroi in my Macbook.

I tried connecting Trezor to Yoroi in my PC again, it went fine. It recovered the wallet. But doing to other devices (my Macbook) won’t allow it.

USB rules and browser USB access restrictions may affect

Is that related to apple devices only? Where can I configure that?

Apple devices’ support for USB devices or security policies affect the identification of devices. I guess so.
There are others who also have this problem with Apple computers.

Metamask, Ronin, and Trezor Suite work fine with my Macbook. It’s just Yoroi.

Then you can ask Yoroi’s official technical support . Maybe it was Yoroi’s problem.

okay, probably is. Thanks for the help!