Possible bug in the "Advanced" method of seed testing (on device)

Trezor Model One, firmware 1.10.3, Win 10, Brave browser.

I wanted to test my seed phrase, via Wallet->Advanced->Check Recovery Seed. The simple method worked, the “Advanced” method (on device) didn’t.

  1. I first tried the “Advanced” method, using letter prompts on the device, I could NOT enter the seed phrase in the correct order. Going in numerical order, in 2 places, the letter prompts did NOT match the word from the correct spot on the list. There was no way to enter the word, as the non-matching letter prompts didn’t allow it. Instead, the prompts matched a word from 2-3 spots further down the list (?). So I entered that other word from further down the list, thinking that maybe I wrote down the words in the wrong order. This happened twice. At the end, the test reported “invalid seed phrase”. No wonder, since there’s no way to enter the words in the proper order. The order seemed numerical, starting at #1 (unlike the on-computer method, which is in random order). I manually counted words in these 2 cases, to verify I was entering the right words.

  2. I did the simpler on-computer test and it worked fine (confirming the right order on my list)

Am I missing something? Does the “Advanced” method (on-device) go word by word down the list, in numerical order, or does it try to shuffle the words, with strange results?

Hi @element,
Have you followed this tutorial? https://wiki.trezor.io/User_manual:Advanced_Recovery
I was not able to reproduce the issue. The more in-detail practical example is also described in our old blog post: https://blog.trezor.io/using-advanced-recovery-on-trezor-4af0eb53c3bb
The words are not requested in a shuffled order. Let us know if that helped!

The process is simple and self-explanatory, so I didn’t need a tutorial. The fact that I got through the first 9 words fine tells me that I was doing things right. But at word #10, the prompts would not allow word #10, instead they led me to the word at spot #13 (I think). Word #11 and #12 wouldn’t match either. It happened again later. It’s like the algo moved in a numerical order, but in two spots it went random (?) If I find the patience and time I’ll try again and take pics of the prompts and the word (if it happens again)

@element Could you submit a ticket at https://trezor.io/support/technical/issue/ and post here your ticket ID? We would take a closer look at it. Also, please don’t post any sensitive information (seed words etc).