Pending transaction ETH

i selected “normal gas”, but the transaction is pending for 1 hour+, how to cancel it?

Hi @Jinxruri

Once the transaction has been broadcasted you cannot cancel it. It will either go through, or not. Trezor Suite now enables to speed up an Ethereum transaction by increasing gas fees. Learn more from our blog post if you like

Next time, to avoid such situation, you can consider setting custom fees. See below.

The first one is the Gas limit. The gas limit refers to the maximum amount of gas user is willing to spend on a particular transaction. Higher gas limits mean that more computational work must be done to execute the smart contract. A standard ETH transfer requires a gas limit of 21,000 units of gas.

The second field is the Gas price and it is up to you what gas price you will set. The higher the gas price, the higher the transaction fee, but the shorter time to get your transaction confirmed. To have some idea what gas price you should set, have a look at ETH Gas Station or Gas Now


My ETH has been pending for 7 hours now. I am afraid to unplug my wallet. This is using Trezor Suite. The amount of gas being used shows pending. I try to bump fee and it says Not enough funds.
What to do?

Hi @Jane_Brown

Please submit an issue by using this form and include your transaction ID so we could have a look at it.

Once you have done it, please send me your Ticket ID to prioritize your issue. Feel free to use PM.

Thank you for your cooperation in advance.


Hi, I am having the same issue I definitely have the funds (0.5 eth left) but it’s not allowing me to increase funds saying: insufficient funds

Thanks for submitting your ticket, please check your inbox.

Me too. Sounds like the ‘bump fee’ is broke in the app. The app didn’t provide enough gas fee up front when I clicked the send button, and I have plenty of fund available and my txn is uncomfirmed for a long time. I’ve submitted a trouble ticket

I’m having the same issue. I got plenty of funds available for gas yet the app thinks I don’t, thus, I’m unable to click the ‘Replace Transaction’.

I as well have a similar issue. I cannot bump the fee cause Trezor suite doesn’t detect the funds (as it seems). Also, the transaction that is pending only shows intermittently (very seldom).


I’m having the same issue. I tried adding more funds but nothing has changed.

Ticket ID: 92946

I’m trying to add futher funds to see if this helps, but don’t want to keep paying fees if it’s not going to help me get my transaction to go through.

Thanks for the ticket ID. We will prioritize your case and one of our agents will get back to you soon.

Thank you. I appreciate it. It seems from comments that i’m not the only person this has happened to. Did not realize I needed to set funds aside manually for gas fees etc. I’m assuming this is the issue. I’ve since added a bit more funds but it wont let me increase the gas fees and keeps saying insufficient funds and transaction pending etc.


Unfortunately, I have the same issue; “Bump fee” is not working and there is a notification that there are no funds which is wrong.

My ticket ID is 94717
Please help unlock my money on Trezor product.

@Cccolas Hi, did you manage to resolve the issue? Can you share how?

Hello @NIYAK I have the same Issue; Ticket number 94717 - can you please help unblock my account?
“Bump fee” function does not see proper ETH balance, and I’m not able to increase transaction Gwei, as a result my whole account it blocked.

Hi, my ETH has been pending for almost an hour now. The gas limit was 21000, gass price is 48 gwei but gas used is pending. Nonce is at 2. How do I get out of this transaction? I tried to bump up the fee but it keep getting the message “Not Enough Funds”. I have submitted a form with my transaction ID. My ticket ID is 94889.

Please help!!


5 days ago I sent ETH transaction with only 22 Gwei.
I could not “Bump fee” because app did not see actual ETH balance and I was getting the message “Not Enough Funds”.

After 5 days, the transaction (which is still pending) is not even visible in Trezor App.

Can you please help unblock my transaction?

I issued ticket number 95010.

@Manequ1’s tx went through successfully.

However, @robert99’s tx has not.

See this video, nicely explained

Hello Pavel

Thank you for the video; it explains how to reset the pending transaction (the one with smallest nounce) using Metamask.

Can you tell, how to send a customized transation nounce transaction with 0 value using Trezor suite?

I know that I need to send 0 ETH transaction:

  • to my account
  • with the Nounce = 2 (as this is the nounce of my pending transaction)
  • with 0 ETH value (here comes another problem; Trezor suite does not allow sending 0 ETH value - it says “Amount is too low”)

Can you please help?

Unfortunately, Trezor Suite doesn’t enable you to perform such action.

For this, you need to use either MetaMask, or any other compatible app such as MyCrypto, MEW etc.

See compatible apps, and how to use them with Trezor Apps - Trezor Wiki

1 Like