Payment never got into my wallet

Hi, recently someone just sent me $75 to my wallet (0xf779fcA5c02Be42a04B66c601EC79F74a35156Cd) (0x49d15084641dd3f5c729eecfcaa645929154ca7b6471b742969a004830f042d8) and the money never actually entered my wallet. Can someone help me please thanks!

Heii @fixwwww

If I am not mistaken your tx is this, form what I can see on the explorer
Screenshot 2022-09-04 at 22.14.40

It comes from an exchange and if I am not mistaken it could be a internal tx

Check here:

It is confirmed on the blockchain you just don’t see it.

If not helpfull just wait a little for comuniity support like @forgi or @radekP

good luck

I already tried to connect my trezor to Metamask and all of the other options aswell and I still can’t see the eth, i don’t know what i should do at this point, I tried everything

Also thats the wrong txid

the one internal is (

ohh ok sorry my bad. just wait a little help will come

1 Like

I hope so man, thanks for the help

what is the address you are connected to in Metamask?