November 10th ETH trasfer not found in My Trezor


On November 10th, I request an address on my Trezor to receive ETH from another wallet. Then I sent from Wallet-XYZ to Trezor using this address and the transaction was completed. I even have an email confirmation with a URL link to see blockchain and a hash number. However, I haven’t received any ETH on My Trezor wallet. Obviously, I already open a ticket at Trezor support but SLA can be up to14 days, and I am pretty nervous regarding what could happen to my ETHs in between this transfer …

As I am new on this matter, I would appreciate any clue about what’s going on or advice regarding a probable mistake from my side.

Please be aware that I have completed some other transfers from Wallet-XYZ to Trezor without any problem.

Does It make sense?

1 Like

Hi @fg060981
This can be for example internal transaction but hard to say with no additional information.
Could you please provide your ticket ID ?
Thank you.

1 Like

Thank you MichalZ … Off course here you are:

Ticket ID: 105350 created Nov 10th

@fg060981 Thanks for the ticket ID, we’ve already replied.

Ok, but please review my reply on email. Is still not clear for me.

Would you?

Is it possible you transferred your ETH on the wrong network?

This happened to me, I transferred from BEP20 network on Metamask wallet to my Trezor which cannot accept BEP20 ETH and I am still trying to figure out how to get it to show up via a Meta Mask wallet. Support here has not yet helped me either.

I found a youtube video about it that has helped a lot of people but it’s still not working for me.

Thank you Swiatekt1984 !

My origin wallet is and they say their network is ERC20 also supported by Trezor. This link apparently demonstrate everything was ok

Any other clue?


I finally use Metamask, link it to My Trezor and voila ! Now I can see my ETH…

Than you very much Swatekt1984 !!

you can’t se your tokens in Trezor Suite because the transferred you have made was an internal transaction. For more information please see following post:

Have you set the custom network RPC for BSC correctly?

You can also use