New Trezor T Issue

Hi,

I just purchased a Trezor T directly from the official Trezor site. I went through the set-up and began using my Trezor.

I sent some Solana and some SPL tokens to my Trezor address. Everything worked fine.

However, when I tried to send the SPL token back out, couple things happened:

  1. It asked me to enter a passphrase to authorize the transaction. I never set up the passphrase (hidden wallet), so that was weird. I read through some other topics and seems like others are also experiencing same issue. I was able to disable it in Trezor Suite.

  2. As I continued to attempt to transfer my token out, my Trezor shows the message in the attached photo while my Trezor suite asked me to confirm recipient address.

  1. When I clicked through on my Trezor, the recipient address is different from the one I entered into the Trezor Suite.

Has my Trezor been compromised or am I doing something wrong? Please help!

I suspect your sending a SOL token of some sort, I’m fairly sure the address your talking about is the token contract address. I found this confusing myself…
But don’t quote me on that, I maybe wrong…

Thanks! You are right, it was my token account under my SOL recipient address. So point #3 is solved.

However, does anyone have more information on my point #1 and #2? Thanks!

Hi @oldman123,

Please, find answers to your questions #1 and #2 below:

  1. We are aware of this issue and currently working on the fix. The workaround is to leave the field empty and confirm.
  2. This message is legitimate when sending SPL tokens. You will be prompted to confirm the rest on the next pages (this one is 1/3 as you can see in the top left corner)