New Trezor One stuck screen: Trezor Bootloader

I just bought a new trezor one and I haven’t set it up yet but when i replugged it to my PC the screen stucked to Trezor Bootloader 1.10.0.

I tried to open it by using Trezor wallet but when it says to confirm the screen hadn’t change. It didn’t give give me options to confirm or cancel it.

I also tried and followed the zidag’s instructions but it didn’t work.

Please see this topic, @nix:

If you haven’t yet got the setup to finish, and therefore haven’t stored any funds in the Trezor yet, you should try to wipe and reset your Trezor One to Factory defaults before you update the Firmware through the Trezor wallet website.

I tried to reset my Trezor One but I can’t confirm it in my device because my screen was stuck.

Try setting it in Bootloader mode by pressing both keys at the same time when you plug in your Trezor. Then navigate to Factory reset on the Trezor wallet website.

Hi I just tried unplugging it, then pressing both keys when I plugged it but still didn’t work. Same screen appears.

Can you connect to Trezor wallet on at all?
Try being at the Trezor wallet website while you set it in the Bootloader mode. Close Trezor Suite first, if you have it open. Other things you can do:

  • Use supported browsers only. Either Chrome or Firefox, also try both in Incognito/privacy mode as well.
  • Clear you browsers cache.
  • Don’t use any VPN, but also certain advanced Firewall or Antivirus settings, browser extensions (AdBlock, Privacy Badger, etc.), may cause connectivity issues, therefore please try to disable them as well.
  • On top of that, use only one application/website/browser tab with Trezor at a time. It is possible that they are clashing each other.

The scree is till stucked I can’t confirm the installation in my device.

Can you wipe it from inside Trezor Suite or from the web wallet?
There should be a red button in the advanced settings, for doing a wipe.