New Trezor one, keeps saying Connect your Trezor

Just bought a new Trezor one, went to install it using the Trezor suite on our main PC, followed the step where you need to plug it out then plug it back in, trezor got stuck on “trezor bootloader 1.10.0” so as the trouble shooting step say try to use different USB cable and plugs it didnt work, we tried to plug it on a laptop and it works, installation was complete. Everything seems working. i decide to plug it back to main PC , windows detected the trezor, it appears no error on the device manager too. However when i open up the trezor suite it wont detect it, keep saying “Connect your Trezor” , i also installed the Trezor bridge and its appearing on my Task manager, I cleared up my chrome browser. We need to use this on our main computer. Hoping anyone have a solution, please help…

Hi @Rochi

When using Windows could you install software called Zadig?
It is a Windows application that installs generic USB drivers, such as WinUSB, libusb-win32/libusb0.sys or libusbK, to help you access USB devices.
Please follow instructions Zadig - Trezor Wiki.
After installation, please restart your browser and computer as well.

Also If you are using a VPN, certain advanced Firewall or Antivirus settings, browser extensions (AdBlock, Privacy Badger, etc.), or some cryptocurrency apps (such as MetaMask), please try to disable them. It is possible that some of these are clashing with Trezor Wallet.

Thank you for this steps but i already did this too,
I followed all this step again just to be sure, disabled the firewall and all chrome extension, cleared the browser.
The computer can detect the Trezor, its just both the app and trezor wallet site is not detecting my trezor. the bridge is on the taskbar too. any help would be appreciated .

Step by step procedure i did:

  1. plug in the Trezor one on our desktop
  2. Trezor screen shows ( went to the site
  3. click “i already own trezor”
  4. prompted me to download Trezor suite 21.8.1
  5. installed the app
  6. app started to tell me to unplug trezor
  7. app says to plug it back
  8. app just keeps loading for around 15mins
  9. trezor started to show “trezor bootloader 1.10.0”
  10. it got stuck there
  11. trouble shooting step says try different usb plugs and cable, it didnt work “trezor bootloader 1.10.0” still appears on trezor screen
  12. went to plug it on the laptop as per troubleshooting step says to use it on different computer.
  13. went to trezor website trezor was detected but there was a button that shows it needs to update
    so i update it.
  14. went to the initial installation along with the pins a seed phrase.
  15. downloaded the trezor suite for the laptop and everything was working.
  16. tried to plug it back to desktop where we first plugged the trezor
  17. open up the trezor suite and bridge is running on the taskbar, pc shows that it detects the trezor
    but the trezor suite still shows “connect your trezor”

Both Desktop and laptop has the same Windows 10 and browser are google chrome, both with updated trezor suite and bridge.

i still cant figure out whats wrong.
tried to clear all cookies and cache on chrome, reinstalled chrome. nothing works.

I tried to check device manager and here is what i found

date was 8/9/2018
im not sure if the driver is up to date, i pressed the update driver but it says that driver is up to date.
I also followed the step from Zadig

this is my taskbar to show that the bridge is running

i dont have any VPN, firewall is disable, cleared browser , its a bit frustrating now because its working on the laptop, and when i put it on the desktop its not being detected by both the app and the site. Please help.

Since you’ve experienced a Trezor One stuck in Bootloader mode, maybe this can help you:

Hi, its not stuck on bootloader mode as i already use a laptop to properly install everything needed for the trezor, it includes the seed phrase and pin.
i was able to use it on the laptop, i even tried to make a ronin hardware wallet on it. My main issue is that it only works on my laptop, but when i plug it on my desktop. the trezor is detected by the device manager but the trezor suite or even the trezor wallet web site cant detect any device, it keeps saying Connect your trezor, even while the trezor is already lit with the icon i chose.

I already did the step you mentioned as ive been monitoring any updates on this community, even while the trezor is in bootloader state the website cant detect it.

Hm. :thinking: There must be something different in the setup of your two PCs, I think.

I guess you’ve tried most things you can try then, but I’ll list a few here, in case you haven’t tried it.

  • Check that you hear a mechanical click sound when you plug in the USB cable
  • Try another USB port on the PC, preferrably one that’s not on a USB hub
  • If you use a USB hub, make sure it’s powered
  • If you use another USB cable than the one that came with your Trezor, check that this cable can transfer data and isn’t just a charging cable
  • Check with Task Manager that process “trezord” runs in your PC
  • Check your version of Trezor Bridge, maybe it needs updating or reinstall
  • Try to quit Trezor Suite and restart it again
  • When you connect your Trezor, listen for the confirmation sound for connection of the device from Windows before you start Trezor Suite
  • If it’s been a long time since you restarted your PC, try that
  • Look for anything more that is different on the laptop, compared to your PC

Not likely, but I list it anyway:

  • Check that any browser plugins don’t interfere with Trezor Bridge. Most importantly, any ad blocker and script blocker.
  • Use only one browser tab at a time with Trezor
  • Try another browser - preferrably newly installed, without any plugins or extentions added

My guess is that the most probable cause is either a) the USB cable, b) the USB port, or c) the bridge.

i really appreciate your help,

Trezor Bridge version
Trezor bridge is working on my taskbar

Trezor suite is 21.8.1

Yes i always here the sound when you plug in any device
trezor detected

-restarted the PC
-re install the trezor suite
-Disable firewall
-I installed Mozilla Fire fox (still didnt work)
-Tried different cable
-plug it on 8 usb plugs at the back and 3 usb on front

any other option?

Not at the moment … I have to sleep on it, I think. My workday is already 14 hours long today. Maybe someone else can suggest what to try. :slight_smile:

Hi @Rochi,

I’m quickly running out of suggestions here, but there are a few more things I’d like you to try.

  • Update your Windows with the last fixes.
  • Run an anti-virus scanner and see if there’s any malware on your PC. Also, clean up your PC with a suited program for removing trackers and cleaning your Registry.
  • Run the PC with as few other programs possible running at the same time.
  • If you are using a VPN or some cryptocurrency apps such as Geth or MetaMask, please try to disable them. It is possible that some of these are clashing with Trezor Wallet or Suite.
  • Try to reinstall Trezor Bridge from this source
  • Check Trezor Bridge Status, available from
  • Check if any other programs are using the same port address (21325) as Trezor Bridge.
  • Then, try it again please, preferably with both supported browsers; Chrome and Firefox in incognito/privacy mode.
  • Try using Trezor Wallet instead of Trezor Suite and see if that works.

Hi @Rochi

Please, try connecting in bootloader mode to Trezor Wallet Trezor Wallet instead of connecting to Trezor Suite. See instructions User manual:Updating the Trezor device firmware - Trezor Wiki

TL;DR [INFO] Trezor stuck in bootloader mode during firmware update

Last but not least, thanks @Petosiris for doing a wonderful job here and listing all other suggestions. Highly appreciated :clap:t4:

1 Like

Bro did you resolve yours? because we have the same problem and now just now whenever i plugged trezor in to my laptop, suite won’t detect my trezor… Can you help me if you happen to fix the problem.

I too just bought TREZOR ONE - The cable wobbles about when it is connected. It is very loose. As it moves the connection is lost then reconnected then lost ! I am horrified ! The build quality is appalling .
Question is - what do I do now ???