Need help. Transaction fail after update trezor bridge

When I tried to trade on dex, metamask told me to update trezor bridge and i did. After that everything just stuck and fail, and with the error msg “wrong address”. How may I solve this issue?

Hi @xycrpt,

Little info to go on here, but I assume you’re trying to secure a coin or token into your hardware wallet. If this is not the case, please add more information about what you’re trying to do.

Make sure you select the right coin/token in Trezor before making the Receive address available to Metmask, then check that you use the right transfer network.

i have the same issue. i can login to trezor suite with my trezor, however every transaction via metamask failes: error: error: unkown address. Please help (asap)

I found the solution the problem: unkown adress & connection issue from metamask and trezor → deactivate the passphrase in the trezor suite…

1 Like

Hi mate, thank you very much for providing a clue here! However I think my problem is the other way: I have a passphrase but after I update Trezor bridge I skipped entering passphrase. Do you know how shall I solve this problem? Thanks a lot!

Hi @Petosiris here is what happened:

Before I did a transaction on metamask trezor hw, I upgraded metamask Trezor bridge when it is asked for, during which process I skipped passphrase input. After that for every transaction I tried on that metamsk trezor hw, it just fail. besides, for every trade I tried on dex, it also fails and show error msg “wrong address”. When these things happen, the trezor hardware it self seems not connected to the computer and nothing pops up on the device at all. Please let me know what else info I can provide and kindly suggest how shall I solve this issue.

1 Like

When you say “metamask Trezor bridge”, is this bridge software supplied by Metamask or the official bridge for Trezor? I know other exchanges use their own bridge with Trezor (Ronin, for instance).

If you don’t have any coins in the Metamask account connected to Trezor, I’d try to create a new Trezor account in Metamask and add Trezor’s public address again.

If you use a Passphrase for a Hidden wallet in your Trezor and skipped the Passphrase input when you connected Trezor to Metamask, you’ve probably connected the Standard wallet instead of the Hidden one. I’d advice you to try and reconnect Trezor and this time enter your Passphrase.

Note that passphrases are case sensitive and if you enter it wrong, Trezor will just create a new wallet.
Also be sure that you enable all the coins/tokens you want to work with in your wallets (the same coins will be visible in both the Standard wallet and any Hidden wallets - regardless if you use them in both types of wallets).

1 Like

This is the link that popped up bridge upgrade reminder, I belive it is from trezor side. I do have some coins in the wallet so I need to recover it. I have a passphrase yes (which was set up when I first received trezor hardware and set it up), but what I did before was to open the desktop trezor suite (during this process I dont enter passphrase and go to standard wallet), and metamask will auto connect to my trezor 1 hardware wallet, everything worked fine. This time after the bridge upgrade, it requested me to input passphrase and I skipped. And the issue I mentioned above appreared.

1 Like

It sounds like you set up your Trezor Standard wallet with Metamask the first time, and after that - when you skipped entering the Passphrase - you also accessed the Standard wallet, which is the default function when no passphrase is given.

Maybe you simply have to disconnect Trezor and reconnect it again to the USB cable, to restart it after the bridge installation. But before you disconnect your Trezor, be sure it’s currently located in the Standard wallet. I’d also advice you to try and restart your PC and browser (where you use Metamask), clear the browser cache, disable any ad and script blockers, and only use one one browser tab at a time with Trezor.

1 Like

I really appreciate your help mate. But I have tried on another PC alr (which I used the same trezor-metamask wallet before), also cannot connect. So I believe restart/reconnect wont help either. I suspect the trezor device could somehow be malfunction I dont know…

If I buy a new trezor device. Input the seed and passphrase. Will I get back my asset in metamask trezor 1 wallet in that way?

1 Like

It’s possible - if your Trezor is malfunctioning, but first we should investigate where the error lies. It could also be at Metamask. Perhaps you can install an earlier Bridge version or try other things too. You should probably submit a support ticket and post your ticket ID here so Community support see it.

By the way, you don’t have to delete your previous post and post another if you want to edit something, just press the pencil symbol below your post.

1 Like

@Petosiris that is another issue I want to raise to trezor team: in this forum when I try reply some one, it just turns out I am replying to my own thread. So I have to delete and reply you again.

about my trezor hw issue I have alr submitted a ticket. but this is sort of urgent so I try to seek help while waiting for email reply.

1 Like

If you press the blue Reply button at the bottom, you reply to the thread, but if you press the Reply link under others posts, you reply to them.

Did you post your Ticket ID in this forum after you submitted your support request?

1 Like

I am having the same issue. The same error occurs (unknown address) and when I tried to connect my Trezor Hardware Wallet to Metamask using another device, the number of the wallet doesn’t show up in the Hardware Wallet options that Trezor provides me with. It’s like it disapeared from the list.

Did you find a solution yet?

Guys, when you get “wrong adddress” error it’s probably a problem with generating an address under a different wallet than the one you login to Metamask with. Please make sure that if you login with a Passphrase in Trezor, you also do the same in Metamask with Trezor - and vice versa. Addresses made with a Passphrase are different from addresses made without a Passphrase. They go to two different wallets.

Edit: Also, check that you send the right coin/token to the address.
Try to make another Trezor connected wallet in Metamask. If you can do that, it’s something wrong in Metamask with your other wallet.

Hello @Petosiris , I already did all those steps but when I want to make a transaction from my metamask it doesn’t allow it and the page freezes. I cannot find anywhere my wallet with funds in trezor suite to place it on another device, I would like to contact you so that you can help me if you have experience trying to communicate with trezor support but there is no response. Can you tell me if you can help me, I would pay your advice.

Do you have a Ticket ID? If so, please post it here.