My Trezor is not connecting

First of all, check if the display is lit when the device is plugged in.

If your device doesn’t light up when connected, try using a different USB cable or USB port, and make sure that you are connecting your Trezor with the cable directly. Please don’t use a USB hub or adapter. Also, if possible, try connecting your Trezor to another computer. Some USB cables do not allow data transfer, so even though your device has power it may not be recognized by your computer.

If it’s lit, find out if the device is recognized by device manager.

If it’s not recognized, perform the troubleshooting steps described above.

If it’s recognized by the device manager, there might be a problem with the drivers

Try (re)installing the newest Trezor Bridge version from this source (once installed, please proceed by clearing your browser’s cache). After successful installation, you should see a process named “trezord” running in your activity/system/task monitor.

If none of the above helped, please contact our customer support: customer support contact form.


I am having a horrendous experience with trezor and its connectivity issues.

When I first installed trezor on my Macbook Pro, it worked fine and was responsive on every request.

After a few weeks, connectivity performance degraded to the point where I had to unplug and plug the trezor back again over 5 times on each session before it could be recognized by the system.

Each time I replugged my trezor, I had to input my pin and waited to see if the computer would recognize it.

Once recognized, I was able to perform 5-10 transactions before connectivity dropped randomly and I had to start all over again.

Many times I resorted to restarting my browser (chrome) and even my laptop.

A few weeks ago, I bought a brand new iMAC M1. Installed the trezor bridge and everything, and my trezor T worked flawlessly, not missing a single connection.

Fast forward a few weeks and I find myself doing the same kind of litanies and rituals as on my old Macbook pro.

I have:

  • :white_check_mark: Reinstalled trezor bridge multiple times.
  • :white_check_mark: Cleared my browsers cache, although I am not even on my browser, I am working with the Trezor Suite native MacOS application.
  • :white_check_mark: There is no “Device Manager” on MacOS.
  • :white_check_mark: Used all USB ports available on the iMac and macbook pro. Generally Mac computers are very robust and all connected devices work out of the box.
  • :white_check_mark: Changed USB-C cables and used my Ledger’s Nano cable without any results. My ledger Nano works flawlessly using both Trezor’s cable and it’s own cable.
  • :white_check_mark: I have observed connectivity issues on both my macbook and my brand new (2021) iMAC M1.
  • :white_check_mark: I’ve been using trezor suite and trying to make the trezor T connect with my browser CLOSED.

I am a software engineer.

Please fix your software.


I’m in the process of setting up a new Trezor T on a new iMac M1. Not a software engineer, just an ignorant user, so I won’t be able to solve complex installation problems. Hope you get an answer.

One thing that is stated in earlier post above is to not use a USB adaptor or hub. iMac M1s do not have any USB ports, only USB-C. So how can one use a Trezor T with a new iMac M1 if you can’t use an adaptor or hub?? Was this issue solved with Trezor Suite?

@Bluehead buy a cable USB-C USB-T ,you can use this cable both on iMac M1 and Android phone

I just plugged my trezor via usb into my mac mini, and went through all the problem solving steps. Still not connecting.

Anyone have a solution for this?

I’m tempted to buy a different wallet from somewhere else.

I just plugged my trezor via usb into my mac mini, and went through all the problem solving steps. Still not connecting.

Anyone have a solution for this?

I’m tempted to buy a different wallet from somewhere else.

I tried on my windows based laptop also.

It is recommended to try this first.

I cannot see or detect my trezor on my old device all of a sudden but when I try it to other device, it’s working. what should I do???
Ticket ID: 129649

maybe there is something wrong with the old computer system.

I still cannot connect my Trezor one although I follow the steps that mentioned above. What should I do? I have read so many posts but still cannot find the solution. Right now I’m waiting for customer support to contact me back.

I can no longer connect either of my Trezor Model Ts to either my computer (Raspberry PI) or to my Smartphone (android). I connected them to my smartphone just days ago. I have tried several cables. I don’t think its the cables. It allows me to enter my PIN, but nothing happens after that.

Browser version upgrades, security settings changes (no ads, no pop-ups) may result in no follow-up response after connection.