My third ETH transaction off my Trezor Suite still hasn't gone through

I’ve tried to put a token on an exchange. I’ve done it numerous times. The first 2 transactions didn’t go through because the fees were too low.

The first one was too low. So I put more eth in. So I “bumped” the transaction but all it did was not combine it but sent a separate transaction.

So I have 2 pending transactions for 21$ instead of 42$ so obviously those are gone

I tried a third for 60$ but it said 51$ was enough. So I let it go through. And now that one is stuck on pending …

I’ve already burned close to 100$ trying to get this off of my trezor suite. Can someone explain what’s going on ? I understand the first two were too small but now my third one with full gas fees won’t let me take it off?


Hi @Dukematch, could you send us a hash of the last transaction? You can either submit a ticket at and enter the hash into the contact form (then please post your ticket ID here), or you can reply to my DM I just sent you.