My device isn't recognized

I bought my trezor one; I followed the instructions that came with it and installed Trezor Bridge, its suite and configured the device. Then I sent my balance from Exodus wallet 4000 ADA to an address generated through these.

For work, personal and ideological (HODL) reasons I forgot them, nor did I use Trezor again.

Months later, with the intention of performing the same operation with other altcoins in my portfolio, I have tried to access both Trezor Suite and Bridge without any results.

Neither of them ran on my laptop, a problem I had on other occasions with Exodus that I solved by reinstalling the executable and so I did with the Suite and the Treasure Bridge, several times.

The result: Bridge does not run in any way and Trezor Suite does not recognize the device that, when connected to the usb port, the screen saver I chose in its configuration appears.

I have tried to whipe and reboot the device but for that I must first recognize my device, is there any way to force the reboot or should I buy a new Trezor device?

Thank you very much for your attention and help

hi @cryptolyon,
I can see you have opened a ticket as well, we will reply to you asap since we need more information.

In the meantime please refer to this post:

I have the same issue. Could you please guide me?
Story: bought trezor, installed but never achieved sending Ada from Exodus. Exodus said my passphrase is too long. And now I can’t log into trezor, changing the long password.