Model T won’t send Bitcoin, freezes at signing transactions

Ticket ID 92397

I’m trying to send Bitcoin from my Trezor Model T to my exchange wallet for the first time. Everything works fine until I try to send I confirm it on the trezor then it seems frozen at signing transactions. The circular indicator on the trezor is about 1/4 of the way around but frozen at that point.

See if this may help:

TL;DR: It may be that the Bitcoin you send has so many transactions connected, that memory in Trezor fills up. Try sending smaller amounts of BTC.

Thank you , I have tried several smaller amounts even setting them to high fees and same results it’s frozen at signing contracts… Yes I’m getting all my payments in Bitcoin from a mining pool deposited directly to my Trezor model T.
Thank you sincerely for the feedback and continued support in resolving this as my BTC trapped in my wallet atm.

I think that the amount of small transactions is the problem here. Hardware wallets like Trezor aren’t meant to be a receiver of so many small transactions of Bitcoin. Instead, you should accumulate the sats rewards in a software wallet or exchange account until the amount is larger (maybe ca. $1,000) and then transfer that amount to the hardware wallet.

I don’t know what the typical amount in sats you get from the mining pool and I have no idea about the memory size in Trezor T, so I can’t calculate how large sum you can transfer out either. However, you should try and transfer smaller amounts to a software or exchange wallet and then transfer the large sum back to Trezor, thereby getting rid of the small transactions.

And change the address you receive sats from the mining pool to a software wallet, for instance.

Maybe Community support have a better idea. You’ve posted your ticket ID above so they’ll contact you. This is solvable but may take time and manual work before it’s fixed.

Good luck! :slight_smile:

1 Like

Thank you again🙏 I have switched it so it’ so my pool will deposit into an exchange wallet successfully. The # of transactions was 15 varying but equal around $9,500 in BTC, if this device is limited then it’s not advertised as so ?
So at least for now I have my BTC moving forward in a wallet I can control… so I still need to figure out how to free all my Bitcoin on my Trezor Model T. Yes I took a ticket for Tech support, says up to 20 days on a response , fingers crossed :crossed_fingers: it doesn’t take that long.

As of firmware 2.4.1, this problem should have been solved.

Theoretically, Trezor can sign any number of inputs/outputs, although it might take some time. In practice, well :woman_shrugging: If you are on latest firmware, that means that the solution was incomplete.

Does the same problem appear if you use Trezor Suite and the Wallet?
Can you tell us roughly how many incoming transactions there are? Is it hundreds? Thousands?

Hello again
I started mining August 11th and the pool has paid out everyday but obviously varying amounts based off price … difficulty etc…
So it has accumulated 15 transactions thus far , but I switched it so my Bitcoin is now going to an exchange wallet until we can resolve this issue with my Trezor model T , holding around $9,300 in BTC…

Hello again
Just want update on forum, it’s been 23 days and nothing from Trezor accept an email sent on August 29 letting me know a ticket would be started but up to 20 days to respond?? This is horrible customer service as my money is literally held hostage by this failing piece of technology.!

So I found the easiest solution was to buy a nano x and recover my Trezor wallet using my seed phrase … then use this Nano x wallet to send my BTC to my exchange wallet hassle free
Paul T
Ps Trezor did finally respond and they have a similar solution using you essentially do what I did using seed phrase to recover to electrum wallet then you have control of your coins again​:wink::pray: