Missing Ronin Wallet on Trezor

I have wallet addresses (scholars) in my trezor that I regularly access and I have not been accessing them for the past few days since I was away.

I saw that 2 of them have the claim date set to today so I have logged on in to ronin, claimed the SLP and passed it on to the 2nd account that was ready for claim. The 2nd account just loads the trezor page infinitely when trying to access, it doesnt prompt on the hardware like the first one. I did all my due diligence (unplugged trezor, clear cache, clear browser, restarted PC, restarted browser)
Got frustrated and since I still have the same wallet with the phrase I decided to delete the wallet linked to my ronin and just manually re-add it instead. To my surprise, I don’t see the wallet ending with …55a6. Yes, I checked and verified that the passphrase was indeed the same as I see the other wallets that have axies in them on the other pages. I just dont particularly see this specific wallet. I tried using Firefox and it was the same.

I did all my googling and research for more than a day now.
Has anyone had this experience before and how you got it fixed?
Any kind of help would be appreciated. Thank you!

Update : I just figured it out. the other address was on the hidden wallet, the problem still stands. It loads indefinitely and wont proceed to the trezor page so I cannot proceed and accept it on my hardware.

hi @xtiandgreat258

  • Make sure, your Trezor is running the latest firmware.
  • After successful installation of Trezor Bridge, you should see “trezord” process running in your activity/system/task monitor. If you cannot see the process running in the background, please try to reinstall it again, from this source https://wallet.trezor.io/#/bridge
  • Then, please check your Trezor Bridge Status, available from http://127.0.0.1:21325/status/
  • Use supported browsers only. Either Chrome or Firefox (try both and try using Incognito/privacy mode as well).
  • Clear your browsers cache.
  • Not only using a VPN, but also certain advanced Firewall or Antivirus settings, browser extensions (AdBlock, Privacy Badger, etc.), may cause connectivity issues, therefore please try to disable them as well.
  • On top of that, use only one application/website/browser tab with Trezor at a time. It is possible that they are clashing each other.

hello friend could you solve the problem? I am in the same situation and the support team has already got rid of me, claiming that I was wrong with the phrase and there is nothing else to do …