Metemask transaction won't complete

The trezor popup happens, I sign it and the it disappears and no transaction happens on metamask.

(using polygon chain)

1 Like

I’m not sure if I have the same problem. I have stored tokens on trezor on polygon and connected to metamask. I was making transactions without any issues, but it looks like a new update does the issue. When I go to sign the transaction - there is popup to connect with trezor, but then nothing happens and I can’t sign the transaction using trezor (as I was doing previously).

I was trying to use Brave instead Chrome - but the same problem. I was trying to access the wallet by connecting trezor on another chrome account - but the wallet address where I have tokens is not visible for some reason

  1. I was thinking about downgrading trezor’s version - is it safe?
  2. The other option could be - exporting private keys from trezor, but I haven’t found a secure way to do that - any recommendation?
  3. any other option? thanks


Most likely you are using the wrong passphrase for the specific wallet that you want to use to make a transaction and that is the reason why Trezor can’t sign it. Try to connect hardware wallet (Trezor) to MetaMask again, can you see your address in step “Select an account”? If not, you are exporting the wrong public keys. Most likely you typing the wrong passphrase. Also, make sure you store the right recovery seed in your Trezor, here you can find how to check it:

for Trezor Model One:
for Trezor Model T:

In case you have the right recovery seed stored in your Trezor, you entering the wrong passphrase.

Your problem is most likely the same as Steffan’s.

Please, use supported browsers only (Chrome and Firefox).

The reason why you can’t see your address while trying to connect to MetaMask via another account is that you using either wrong recovery seed or passphrase. Also, try to check your recovery seed, if you have the right recovery seed stored in Trezor, you entering the wrong passphrase.

  1. You can try, most likely it will not help you to solve your issue.
  2. We can’t recommend exporting the public keys as they can be confirmed online.
  3. You need to enter the right passphrase. Remember that passphrase can be any word or any set of letters (in ASCII format and with 50 characters max), it is case sensitive, and empty space is also a valid character, please also think of a different keyboard layout you could have used.

it’s finally working!

  • I tried to allow popups (I’m not sure if this helped)
  • I also allowed passphrase which I had before, for some users this helped not not for me. when I allowed passphrase again it works now

…thank you for your help, it’s working again, have a great day!