Metamask-used, hidden Trezor Wallet does not show balances in Suite - only in Metamask

Hello everyone

I cannot see my Metamask-linked hidden wallets in Trezor:

Intro: I had a Trezor One bought only intended to use with Metamask. So I setup this new Trezor One from scratch and I also setup a new Metamask Account on Brave for it. I am aware of the fact, that the default MM-Wallet is “hot” and I therefore will keep it untouched.

On the Trezor side I setup according the standard setup procedure a default wallet (I assume), did never enter a Passphrase and after I had Trezor setup I deactivated the Passphrase Option in the settings (I did/dont want to use this feature).

After that, I went into MM and connected with the newly setup Trezor and it showed me a list of ETH Wallets (today, I assume these all were hidden wallets…). So I picked the first possible one, as far as I remember there was one above which I could not even tick (…). But ok, it worked and it exportet the chosen wallet with Public Key into MM. I have done this process twice and do now have two Trezor Keys linked with MM. Everything works fine and for every transaction I make it properly asks me to export the PK from Terzor and I can confirm with the Trezor HW by clicking.

After a few weeks I wanted to check the balances of these MM used Wallets for the first time also in the Trezor Suite. But I could not see them. If I am logged in into my Trezor Suite, in the left upper corner it shows “Name of my Trezor” and below it “Hidden Wallet”. And as written, I had disabled the Passphrase Option after the setup. So I started to wonder why I had hidden wallet written there.

I had read a lot of (horror) stories before my setup - people had messed-up whilst migrating Wallets to HW-secure them with Trezor etc. and ended up having chaos relted to standard vs hidden wallets. That is the reason I did turn this option off from the beginning.

Now I assume, that with enabling Passhprase again in my Trezor Suite, it may directly lead to the creation of a new hidden wallet again or, even worse corrupt these existing ones mentioned above!?

I really feel not comfortable with this Passphrase thing at all at this very moment. That I why I decided to ask the community first, before doing a next step.

Can someone help me please: I want to see these two (now hidden) wallet in Trezor Suite. But I am sure I have never set or entered a Passphrase to create them. What shall I do?

Thank you so much !!

Hi @Alex1984, if you can no longer see your ETH addresses in your wallet, you are using a wrong private keys (seed/+passphrase, if used).
Please go to Trezor Suite - Settings - Application - Reset app. Let me know if after resetting the app you were able to access Standard account. However, if you are accessing a Hidden wallet with leaving passphrase prompt blank, you are actually accessing your Standard wallet.

Have you recovered your wallet with a seed recently? If you are 100% certain this is not related to using a wrong passphrase, than the seed should have your focus. However, in the majority of cases users admit that a wrong passphrase was cause of the issue.

Do you know the ETH address that holds your coins? If yes, you can try the tool https://findeth.io/flow/address and search for the address with your Trezor. It will tell you whether the address is associated with the keys in your Trezor.

I tried everything you say, but looks like my address totally disappear from my trezor

Hi @fili, addresses cannot disappear - they are connected with the respective keys forever and cannot be changed after time. If you do not see your receiving address, you are using a different private keys.

Those are the only potential causes:

  1. You have a wrong seed in your device - try to wipe the device (it has to be done through the web Trezor Wallet https://wallet.trezor.io/) and upon reconnecting, perform the Recovery process in which you import the correct seed to the device.
  2. You are typing in a wrong passphrase when accessing a hidden wallet - check all possible variations for the possible mistype (passphrase length can be 50 characters max, it is case-sensitive and all ASCII characters count - even empty space is a character), make sure that you have set the correct keyboard layout and when typing the passphrase click on “Show passphrase” so you can see what you’re actually typing
  3. Your funds are not in a passphrase-protected (hidden) wallet, but you are typing in a passphrase when accessing wallet anyway - do not type in any passphrase when you are accessing the web Trezor Wallet or Trezor Suite. In Trezor Suite the passphrase-protected wallet is called hidden, therefore, if you are sure your funds are not secured by a passphrase, do not open any hidden wallets - always access only the Standard one.

I deposited my funds from METAMASK, until there everything ok. the problem started when I tried to withdraw from the metamask account linked with TREZOR.

I performed the recovery processs, I tried without passphrase because I never used any for this process, I tried with all the passphrase I used before, I checked everything with the website findeth inside my Trezor, I tried to find the address with the metamask process, I used my seed in metamask, myetherwallet, etc etc, but it looks like was a bridge problem of trezor and my wallet dissapear from my trezor. I have videos using that before, and now it is stuck.

here I show you the address I cant get access, and trezor can’t tolerate it, I can’t have this huge lost of funds because something was wrong between the device and my laptop. im very disappoint with trezor and how it worked for me. I would like someone from Trezor contact with me to try to solve this big lost of funds.

address:
you can check the balance is this website because.i used the avalanche chain.

0x57d9E810C484E7bc4A7Ed256A4CDFF71196705b1

Dear NIYAK
Thank you for your feedback.
I was able to access the Standard Account by just enabling the Passphrase Option (which ist confusing…), restart Trezor and then I can choose to enter Standard or Hidden Wallets.
But there, in the Standard Wallet I cannot see the MM linked ETH addresses?
What really confuses me is, that as soon as I “disable” Passphrase option again, my wallet will show in the upper left corner of the Suite as “Hidden wallet #”. As soon as I enable Passphrae and restart Trezor I can choose between entering with Standard Wallet or Hidden wallet.
I have never recovered my wallet since original setup. I assume it has to do with the chronological order of enabling/disabling Passphrase. Because I am 100 % sure, that everytime I connected MM with Trezor to export a new wallet it did not ask for my Passphrase (because I had disabled it from the beginning after my Trezor setup). Phu…?

1 Like

@NIYAK update: After “enabling” Passphrase and accessing it with Passphrase (blank) my Trezor now names “Standard wallet” again and Ethereum #1 account is identical with PC from MM. But the second ETH account is still not showing up.

it has to be a bug from trezor, they need to update the firmware ASAP, because we are losing our funds because of trezor. I won’t trust them anymore. try to find your account with findeth or mycrypto. I still wait trezor support reply me with something useful, my address is lost.

If you’ve tried to search for the specific address with the findETH tool and the address was not found, you are not using correct private keys. As explained in my previous posts, the addresses cannot be changed within one wallet, therefore it’s important to search for the correct private keys, as the keys are what represents the wallet.

Have you tried the findETH tool? https://findeth.io/flow/address
Search with your Trezor for the ETH address that holds your coins. The results will tell you whether you are using the correct private keys.

Yes, I have tried it. But since I only use C-Chain Network on MM I am afraid this tool will not help me find any tokens on any of my addresses? Can it be that Trezor Suite does not show any C-Chain funds at all?

I found all the MM linked PC addresses on findeth.io and it seem that they all derive from the same derivation path. But still they are not shown in Trezor Suite. No address nor funds are visible?

@Alex1984 I see where the problem is. Trezor Suite does not support all the coins that you can use in Metamask connected with Trezor. Please check this list https://trezor.io/coins where you can see what coins and tokens can actually be used in Trezor Suite. However, if you want to use any tokens that are not listed, it is impossible to use those in Trezor Suite.

@NIYAK Ok, so this narrows to a closure of this case - thank you! Only two questions remaining: a) Eventhough trezor-Suite is not supporting these coins it does not mean that there is technically seen any problem to have them secured with Trezor/MM - right? b) Is there any other Trezor “viewer” which works fine with Trezor HW?

Sure, you can still use Metamask with your Trezor without any worries. Some coins just cannot be used in Trezor Suite directly, but since you are accessing the third-party app with your Trezor, your private keys are still secured, as Trezor does not expose them to the third-party wallet.
There are more third-party wallets that can be connected with Trezor: https://wiki.trezor.io/Apps

1 Like

One more thing that i have noticed. If you use MM to connect to ETC (MATIC or some other supported) network, it will use your ETH addresses (not ETC) from the suite, so you will not see your MM (ETC) transactions in the suite, but otherwise all is working fine - sending/receiving with MM. Both standard and hidden wallets can be used without problems, just the transactions are shown in MM only.
If at a lather time Trezor team adds to the suite the option to list/use available ETH addresses on the ETC tab, that would be perfect

EDIT: checking for the ETC address used with FindETH, shows:
Address found at m/44’/60’/0’/0/0!