Metamask trezor fails to send smooth love potion aka SLP

I encountered an error when trying to use metamask send to an exchange wallet. This metamask wallet address is linked to a trezor model T.

So supposedly i am to receive the prompt on the trezor to authorize the transaction yes? but what happened instead was that metamask reports a failed transaction and i end up having to pay gas for a failed transaction… wtf…

so i tried and again after having unlocked the trezor model t before hand, and also having trezor suite open as well, all at the ready. still same problem, metamask reports an error.

The only solution i could find was to use the trezor suite app to send SLP to the exchange. This worked without a hitch.

But what worries me is, basically i cannot effectively use metamask if i can’t trust it to work cauz i may incur transaction fees for a transaction that can’t go through because of some problem between the trezor and metamask.

I thought maybe it was something i did wrong or did not understand, but then i saw this thread dated back many months ago that describes the similar problem i am having.

Does trezor know anything about this problem? or is working on a solution so we can trust that trezor and metamask will work correctly without us worrying about it erroring out and costing us for these fails transactions?

1 Like

@Langly1087 by any chance have u had any experience with this issue? because like me, you are also using the trezor for axie, so you also use the same eth addy from trezor to setup both metamask and ronin.

Did you have any bad experience when trying to transfer slp using the metamask send? just wondering. Or is this issue only specific to me and a few other users only o-O;

1 Like

Hmmm, I have not tried sending from the MetaMask with trezor connected to an exchange yet. I’ve only used the Ronin Bridge, and Uniswap with my Trezor connected.

What was the gas fee when you made the transaction? It sounds like you did everything correctly. Its great to hear that the Trezor Suite transfer worked tho. At least you aren’t completely stuck. And because that worked, I’m led to believe it is a MetaMask issue more so than a Trezor issue. I’ll do some research and see what I can find out.

I will report back if I find anything out.

1 Like

ty i appreciate.

well so far i’ve been using the trezor metamask, mostly for pairing with the ronin wallet.

so at most i login using metamask to the axie website. or i authenticate the ronin wallet transactions (this works so far, except for one event where you are unable to reject transaction, as ronin wallet will still go ahead with moving your assets into a pending purgatory even if you click reject. something to be mindful of)

i tried that metamask toe xchange to move slp, it failed 2-3 times. guess i think was around 51 usd or something… not too happy about that :{

i just noticed this in changelogs

Version 10.0.2

@metamaskbot metamaskbot released this 8 days ago


  • #11818: Add gas recommendation options to cancel and speed up popovers


  • #11853: Allow editing custom gas while estimate is loading
  • #11862: Increase saliency of mobile sync warning text
  • #11872: Default gas limit in edit gas popover to 0 when estimates are unavailable
  • #11873: Update copy on tooltip shown when dapp suggests gas fees


  • #11852: Improve flashing behavior for loading gas estimates (Confirmation Screen)
  • #11874: Fixes Trezor pairing integration

notice the last one that mentions trezor.

in metamask i found these mentioned trezor

Just in case i lodged a reported here as well

1 Like

Great stuff moogle! Keep us updated! Seems like it is a MetaMask issue then…

1 Like

Just an update

So i received my SLP to my Trezor metamask address.

I open the OFFICIAL chrome web browser. Then i expand metamask (to prevent accidentally closing metamask)

I unlock Trezor beforehand. I also have trezor suite opened.

Next i go metamask trezor account open, and do a send. I put in the destination wallet to an exchange that accepts slp deposits.

I obviously check the gas fees.

Then i click send confirm. Then trezor processes seem to work. I get the prompts on the browser and on the device. I go through the trezor hardware verification process (this works).

Now the transaction is pending.

So i checked the gas fees and i noticed it went up. So apparently i took too long or something, verifying the transaction when using the trezor. So what i did was, click speed up in metamask.

This cancelled the existing transfer and re-does it again using the new gwei (which i increased from 70 to 100 GWEI). Gas limit i didn’t know what to put so i left it at default. Because when i tried to change gas limit to like 210,000, the fee estimate scared the bejesus out of me.

So the transfer was resent at the new gwei price. I later confirmed that the previous transfer was not charged, because it was not included into any blocks. Reading from the FAQ this then means as if no transfer was sent in the first place, so no transaction fee got charged for that cancelled transfer.

The 2nd transfer that replaced the first did go through. The fee was around 14 USD or something. Not happy about that, but considering my manager had reduced the gas fees from ronin to metamask for free, i can’t complain much (could have been much worse).

So in summary, it worked.

I don’t know what changed. This is what i can think of

  1. Metamask and unchromium ungoogled DO NOT WORK. Which explains why using the default chrome worked this time around (i can’t remember if i tried the original chrome last time on my 2nd/3rd attempt, so i’m not sure if this was the reason it didn’t work last time)

  2. there was an update in metamask that solved this issue

I don’t know the cause, but all i can tell you definitely was that this time the processes worked fine for metamask + trezor.


other possible issues to be mindful of

The issue seems to appear when Trezor has not yet been “logged in” with PIN before interacting with MM.

some great care needs to be taken when handling trezor with metamask.

  1. make sure you use the default chrome
  2. disable any plugins that may interfere with metamask. like if u are on uniswap, make sure the adblocker ublock is deactivated for that site
  3. make sure you plug in the trezor beforehand, and unlock it.
  4. possibly even run the trezor suite also beforehand (a lot of the web stuff require the trezor bridge, which requires the trezor suite app to be actively running, or it will complain about not having an active bridge)

just things i’ve learned so far when using metamask with the trezor.

that said the recent slp transfer using metamask+ trezor using the metamask send function, went without a hitch. However to avoid the issues, the steps mentioned should probly be adhered to, to avoid any possible issues that may result in failed transaction (and worse a possible a charge for a failed transaction)


This is some great information Moogle. Thank you for sharing!

1 Like

1 Like

I’d love to have you join my discord moogle. I have a lot of people join it from my videos that ask for help. I would love to have another volunteer to help answer questions when I’m not availble. Let me know if you’re interested, and I’ll share the link.

1 Like

oo i’m interested. in fact i also run my own discord (a small one) for my axie scholarship.

But yeah i got some time to participate in your discord.

Just heads up, i don’t consider myself an expert per say on crypto. I am continously studying/researching on crypto, and i do know more than the average newbie. But i wouldn’t dare claim i am more knowledgeable than the experts out there.

So far i’ve been dabbling and experimenting with crypto stuff in order to learn. So that’s where i am at :} so if you are ok with that, yeah then i don’t mind. i just didn’t want to give a false impression that im some big short expert, i’m not >_<:

anyway helping others with basics is actually one of my hobbies ^-^; in fact i started a patreon group for fun to help on that end. so that is where i am coming from.

I’m very much the same as you. Definitely not an expert by any means. But growing my knowledge each day.

Ainz on discord :blush: in case u r wondering

1 Like

``Hello. I´m a new Trezor user that need some help. I connected my Trezor T in Metamask`and started by sending wsMEMO (staked $TIME) from my Metamask which went fine. Next I sent spLP (FTM & TSHARE pool token). Now I can´t deposit back in the pool or send tokens back to my Metamask account. A window pops up and transaction gets rejected and says signature doesn´t match or something. Tried to install Trezor on another pc but I was only able to create another Trezor wallet and don´t understand how to access the wallet I created on the other pc. I can see my assets in Metamask but not in the Trezor suite. I can´t find how to add custom tokens in the suite either. I haven´t tried to withdraw my wsMEMO so I don´t know if that´s possible. Both tokens I´ve sent are not erc20 tokens, the tokens I´ve sent is in Avalanche and Fantom opera network. Can someone please advise me how I can get acess to my assets?
Sincerly Agge
type or paste code here

MetaMask is preventing you from spending your funds because the (appropriate) private key is missing. These private keys for signing transactions are derived from the combination of seed stored on Trezor device and passphrase (if enabled and used).
Hence, if different seed and/or a different passphrase is used then the private key differs and cannot be used.

You can add only ERC-20 tokens (on ETH network), so the token needs to be found on
Once you find it just copy its contract address and add it to Suite - navigate to your ETH account in and click on three dots (right up corner).

Since those are not ERC20 tokens they have to be managed with a third party wallet (where appropriate network can be set). such as MEW or Metamask.

MichalZ - Thank You so much for answer, I´m in desperate need of help because I can not fully understand how many wrong things I have done. I have used metamask for a couple of months so I know that I have to send on the right network but this time I followed a youtube video and even though that I saw that I created a eth wallet I sent tokens from other networks, I don´t understand how I could be so stupid. But I can see the assets in my metamask/trezor account so I guess they´re not gone. I did something similar once in my bsc wallet and that time I finally found a solution a got my money back. If You know how I can get my money back and if You´re willing to explain step by step what I need to do I´ll double the reward.

Could you please open a ticket using this form and include Tx ID(s) of transaction(s) in question ?
Also please get back to me here with ticket ID so I could answer you asap.

Hi Michal. I just sent You the form with subject: Help with tokens sent to wrong network.
I couldn´t find any ticket ID or don´t understand where to find it. My mail is [email protected] if You can find my message from that info instead perhaps?