Matic stuck on Trezor connected to Metamask

I purchased a Trezor One in order to protect my funds on Aave. I’ve been using Polygon network on Aave.
After the purchase, I set up an account, then linked it to Metamask.

I played around, in order to check if everything is alright, I managed to send some funds out of the account (which now calms me). That was a week ago.

Tonight I sent more Matic to that account, and cannot send them out.
Here is how the sending steps are:


And here Metamask freezes. The loading GIF stops turning around.
In the end, Metamask pops up the window: Transaction # Failed!

In the Trezor Suite, there are no Matic tokens, neither I could add such asset address, but I guess it’s irrelevant since I managed to send out some tokens last week.
Pls help. :confused:

Tried again increasing the gas fees, and to my Binance address (which was saved on the MM). Same issue. But now I realised, that another window pops up:
Which means: “Website doesn’t;t respond, You can wait till it responds, or close it. WAIT / CLOSE WEBSITE” And after some time the Failed transaction window pops up.

Edit 2:
I opened Brave browser, where my trezor was connected to same Metamask Wallet, but another Trezor account. I managed to transfer funds in and out successfully.
So I connected this Trezor account that worked on Brave to the Chrome browser (my main bowser), and realised, that Metamask doesn’t see the account with the problems. It can see only the other account (that i played on Brave).

Edit 3: Im certain I haven’t set any passphrase


I don’t know if what I say now is related to your issue, but please note that Metamask always connects to Trezor through a 3rd party site. That is, you have to go to the third party site first and connect Trezor there and then it’ll be connected to Metamask. Check that it says Connected at the top of the Metamask plugin in Chrome, before you use it. If you try to send funds directly to your Trezor Metamask account it won’t work.

1 Like

Hmm. I entered Aave, and managed to deposit 1 Matic, only once with this account, yet it is not seen in “Activity”.
Any other deposit, or withdrawal attempts stop on Metamask crash, just before launching Trezor window. Sometimes it gets through, to Trezor window, yet it crashes later. Below lagged Metamask.

It seems I had two issues, and probably You have resolved one of them. It is a huge relief! Thank you good human being! Wouldn’t you be offended if I tip you when I will manage to successfully release my matic?

1 Like

Just happy to be of help, @WoDo. :slight_smile:

I wouldn’t be offended if you tip me, but it’s not necessary. Thanks anyway!

I keep trying to withdraw the funds to any other account. The metamask still crashes. Sometimes i pass through Trezor veryfiacation, but the transactions always fail.

Is there a possibility to import such account to another browser? I tried, but Metamask cant see this particular adress in my trezor.
I feel panic again.

Guys, it freezes here:

The metamask shuts down until Chrome pops up the notification of failded transaction. It sais the reason of failed transaction is “Unknown adress”. Yet i try to send it to all of my adresses; binance and metamask adresses.
Its always this message. There is no logs of those transactions on “Activity”

Hey @Langly1087,

I have same issue as brothers above, particulary RMAT_09 for example.

I am 100% certain, that i have not created a hidden wallet.
I am 100% certain i have proper seeds, but i dont know how to use them. Please, instruct me step by step how to recover with this account with seeds, i am in panic, pls make it simple.

I tried to login to MEW, as RMAT_09, and couldn’t see the adress with the funds as well. :frowning:

Here is my thread with all screenshots: Matic stuck on Trezor connected to Metamask - #8 by WoDo

My funds (Matic) are on polygon, so they were not seen i nTrezor Suite, only on the Metamask.

Brother, remove the PIN and passphrase from your trezor and it will fix it. I spent 5 hours trying to mess around with this, finally managed :slight_smile:

I am having the same problem as above. I tried removing pin and passphrase but experiencing the same issue. Im seeing this same problem reported all over, but no real solution. Its pretty unbelievable that people are keeping millions of dollars in these wallets with basically no support from Trezor or Metamask on these issues.

At least if could recover the wallet from a new device that would be something. I can recover the MM wallet easily enough, but importing the hardware wallet doesn’t bring up any of the addresses previously linking to meta mask.

I am experiencing similar or same issues with Metamask connected with Trezor as a hardware wallet. I’ve tried different browsers, clearing cache, resetting metamask, recoving seeds - nada. Is the issue:

-That the seed phrase of MetaMask doesnt match the seed phrase of the Trezor?

-The MetaMask wallet address doesnt match or wasnt linked properly to the Trezor wallet address?

-That the Trezor wallet is Hidden and not Standard?

-Is the passphrase on the Hidden wallet somehow triggering a 25th word in the seed that MetaMask cannot read? (Ive tried turning off PIN and Passphrase to no avail)

-Does the exact sequence of accounts in Metamask have to match DIRECTLY the sequence of accounts in Trezor? (2nd to 2nd; 3rd to 3rd; 4th to 4th)

When I attempt to connect the Trezor to a new Metamask “trezor” account; the wallet address of the Trezor does not appear to be linked.

Ive tried recovering using the seedphrase from Trezor into a new wallet. The assets do not appear! Somehow they are trapped in the MetaMask wallet?

I can view my ETH in MetaMask and the NFTs in Opensea tied to this MM>Trezor account but cannot SEND them anywhere

same passphrase will open the same wallet. If you cannot see it you are using wrong one.

Please, watch this video: