'manifest not set' error message from Metamask

I have my trezor connected to my laptop. I also have my nfts on my trezor. I can go to Opensea and open up my Metamask wallet to view the nfts I have stored on my trezor. However, when I try to ‘connect hardware wallet’ within MM in order to actually perform any transaction with my nfts on the trezor I get this message:

‘Manifest not set. Read more at connect/index.md at develop · trezor/connect · GitHub

When I visit the web page listed, it is a ton of coding verbage that I dont understand at all. Is there a fix for this, or does anyone know exactly what ‘manifest not set’ means? What should I do?

Hi @jay5555,

Please confirm the following:

  • Make sure, your Trezor is running the latest firmware and you have the latest version of MetaMask extension installed. If so, please try to reinstall MetaMask extension.
  • Also, make sure you have the latest version of Trezor Bridge, you should see “trezord” process running in your activity/system/task manager. If you cannot see the process running in the background, please try to reinstall it again. The latest version of Trezor Bridge can be downloaded from this source source Trezor Suite
  • Use supported browsers only. Either Chrome or Firefox (try both and try using Incognito/privacy mode as well).
  • Clear your browser’s cache.

the ‘manifest not set’ github page says that I have to set up an email with trezor and give them a url…man, i don’t know how to do that stuff. btw, everything you mentioned above is good: updated firmware, updated trezor suite, and metamask ext is latest update.

This information is intended for developers of 3rd party app which integrates Trezor Connect. Not for users. There is no need for you to set up an email with Trezor or give a URL.

The issue is connected with MetaMask. Please, try to reinstall the MetaMask extension and make sure to try in both supported browsers - Chrome and Firefox (try both and try using Incognito/privacy mode as well). Also, make sure to clear your browser’s cache.


I’ve tried everything, reinstalled trezor suite, reinstalled the latest firmware update, tried on chrome and firefox, cleared the cache, reinstalled chrome and firefox (so reinstalled metamask too), tried in incognito mode…

Nothing is working and I still can’t connect my trezor to metamask.
Important to note: trezor was connected to metamask and everything was working well until yesterday when I tried to send usdc from my trezor to another wallet using metamask, and it didn’t work and was already sending me the “manifest not set” error. So i removed my trezor from metamask before trying to add it back, and that’s when it showed the error before even letting me add my trezor back to metamask.

I’ve contacted metamask support and they’re adamant that it is a trezor issue, as indicated by the fact that it the error redirects me to the link on github made by Trezor.

Please help

Try to connect your Trezor to MetaMask also on a different computer. Do you see the same error message there?