Issue offline tx Ethereum with trezorctl

So I’ve been trying for quite a while to sign a simple ethereum transfer transaction using trezorctl on an offline airgapped computer using Windows. I have followed the instructions to install trezorctl and it appears to be working fine.

However, if I do the following command:

trezorctl ethereum sign-tx --chain-id 1 --address “m/44’/60’/0’/0/0” --gas-limit 21000 --gas-price “22gwei” --nonce 0 --max-gas-fee “22gwei” --max-priority-fee “0.1gwei” --eip2718-type 2 0xe9c96Da78348f90023E0eeEB53333f530103d576 1eth

then I get the following raw tx output (changed accounts for privacy purposes)


I put this raw transaction into a decoder here, and everything looks good.

“chainId”: “1”,
“type”: “EIP-1559”,
“valid”: true,
“hash”: “0x684c196880650de3bceb3ee7316cb532778589b010283d8810b9c67b9e7c53c5”,
“nonce”: “0”,
“gasLimit”: “21000”,
“maxFeePerGas”: “22000000000”,
“maxPriorityFeePerGas”: “100000000”,
“from”: “0xdD044ed1004042490eCD97E9206a9202027e9529”,
“to”: “0xe9c96da78348f90023e0eeeb53333f530103d576”,
“publicKey”: “0x04de55463c0274bfbfdc0f5dcd3d21b0532dd0d03c3feb03181e3a523a2b9e55d1b680f47d81fb6473390cb704d616b1f45a5a945ce9489b202200d84c974ab733”,
“value”: “1000000000000000000”,
“v”: “00”,
“r”: “a4c49efa6793b4d8d54d2c710843635a1312323934ba3ea468d65a45799de64d”,
“s”: “7a293b8f9270855632598629a82ace21046c361ced7818c3d713232f6910f543”

However, when I try to publish this on etherscan I get the following error

Error! Unable To Broadcast Txn : {“jsonrpc”:“2.0”,“id”:1,“error”:{“code”:-32000,“message”:“rlp: non-canonical size information for types.DynamicFeeTx”}}

I’ve tried researching what this error means with no luck. I’m not sure if I’m feeding bad inputs into trezorctl, but after experimenting with many different options I get the same result.

For those who may find this in the future I figured out a solution.

I uninstalled everything and reinstalled python for Windows as well as pip3 install trezor[ethereum,hidapi]

After Python installed, I made sure to disable max length that popped up at the end (I think this was the issue).

After this, everything worked fine!