Importing Account on Metamask

I have a problem which I cannot find an answer to so perhaps if I explain what’s happened

  1. I purchased some UFO Token on Uniswap and stored it on Metamask which was visible
  2. I tried to swap some of the UFO Token for Eth using the Swap feature and it came up with an error message
  3. I reloaded the Metamask Chrome extension and it asked for my seed phrase and password which I did
  4. UFO Token is no longer visible and I have tried adding custom token and its still not showing (Starting to worry)
  5. I logged into my Trezor wallet and can see the UFO Token and transaction so it is there
  6. Tried to Import Account on Metamask where it asks for the Private key or Json file but I do not know where to access the private key

Am I along the right lines here that if I import a new account using my Trezor private key then the UFO Token should appear in Metamask. This is so confusing and don’t know where to turn to try and access my UFO Token in Metamask so any advice would be greatly appreciated

Hi @Samaar01, if you see the tokens in Trezor Suite, the tokens are secured by the private keys in your Trezor device, therefore, if order to access the tokens in Metamask, you have to access the Metamask using your Trezor.
Please follow this tutorial: https://wiki.trezor.io/Apps:MetaMask