Icannot connect to my ronin wallets

You might have gotten your answer already, but Sky Mavis did a design and coding update on the Ronin wallet. The blue bubble no longer shows, and you no longer have to create a ronin-sub account in order to connect the hardware wallet.

You can now connect the hardware wallet without a subaccount created. Once you do that, you will see the “Trezor 1” subaccount connected to the Ronin Wallet. If you click on that, you’ll be able to see the blue hardware bubble that you are looking for.

1 Like


I bought a Trezor wallet a month ago to provide extra protection to my Ronin wallet.

I’ve never connected my Trezor wallet to my Ronin, and when I clicked on the Ronin’s extension, there’s no connection also to any hardware wallet (In this case, Trezor).

But whenever I tried to connect, I couldn’t find the Ronin accounts that I want.

Is there something that I did wrong or any resolution for this?

Thanks a lot!

Hello @nel,

Take a look at this post and see if the two videos linked there can help.

Hi @Petosiris , many thanks for your reply!

I did watch those videos actually before posting this thread. In the video, when he connects the Trezor with Metamask and Ronin, he has everything listed there.

Meanwhile, on my side, I’ve never connected my Trezor, but when I tried to connect, I can’t seem to find my corrent Ronin (or even Metamask - according to that video).

Not sure what’s the fix since it’s been 1 month I’ve been trying.

You have to create a new Ronin account paired with your Trezor. See here.

Note that how to use Ronin is outside the scope of this forum. However, there are many posts and some solutions here, if you want to search for an answer. Otherwise I’d advice you to contact Ronin support.

Hey there Nel,

I’d be happy to help you out in a private video call over on my discord. My videos, while detailed and thorough, can be quite confusing for new users of the technology. Join my discord and comment in the Trezor Support channel. Let’s see if we can get down to the bottom of your problem.

@Petosiris Feel free to direct people who are having issues with their Ronin/Trezor set-up to my discord. I am more active on there than these forums. My Axie Infinity Content creation and twitch streams have kind of taken off and my time has become quite limited.
I have a lot of Axie users who come into my discord whom which I help out with their Trezor issues. It is my pleasure and honor to help them out.


Ok, that sounds great. Thanks for helping people, Byron! :+1:


Feel free to copy that discord link and give it to the other support staff of the forums to hand out to people that are having issues with their Ronin/Trezor connection.

Not that I want to take away work from you all on these forums lol. I just want to do my best to help out the community that will only keep growing. And if my Discord can become a hub for Ronin/Trezor users, then that would be great not just for my growth, but the growth of Axie Infiity and the Trezor collaboration.
I have a strong support staff of PH speakers in my discord that use the Trezor and I or they can jump on video calls with people to troubleshoot their issues. I’ve already been doing this with people who come in from my youtube videos and have even helped some 6 figure operations turn to the Trezor for their security.

1 Like

Great! I certainly don’t mind if you take away some work from these forums. :laughing: There surely are a lot of frustrated Ronin users who need help, so it’s great that they may get help in your Discord channel. I also hope this eventually makes you some monetary rewards through your YouTube channel. Thanks for being such a positive force! :clap:

1 Like

One day at a time my friend, one day at a time. And this is only one NFT game really hitting the market…Wait till more NFT games start hitting the market… :scream: :scream: lol.

1 Like

Oh, I can’t wait for that … :sweat_smile:

1 Like

Just saw your video, great content as usually Byron!

Many thanks for what you do for (not only Axie Infinity) community man, it is much appreciated.

Hello can anyone help me. All my assets are in my trezor ronin account. I reinstall my ronin Wallet extension. I login using my ronin account that has no trezor and when i connect hardware, my ronin trezor address are not on the 50 list address on trezor. Can someone help me to ge back my account. Or can i go to trezor’s company. I need to get back my assets or my parents get mad at me. Huhu


Please see this post and consider trying Byron’s Discord channel.

I bought a trezor for protection of my axies. I connected several hardware wallets and it was all good except for 1 trezor subaccount that cannot send slp to the other subaccounts.

I uninstalled and reinstalled my ronin extension and connected the wallets from my trezor. But I can’t find 3 ronin addresses from the trezor lists. I almost connected everything except for the 3 ronin addresses and I’m a bit paranoid because those ronin accounts have assets in it such as axies and slp.

I only have 1 passphrase that consist of 12 words and pin numbers from my trezor. I don’t have a hidden wallet.

Good day to all I would like to ask why I cannot access my existing ronin account under trezor, I use my usual pass phrase but my existing account is not there anymore please help me. Its either I forgot my pass phrase is there any chance to retrieve my forgotten pass phrase?

Good day to all I would like to ask why I cannot access my existing ronin account under trezor, I use my usual pass phrase but my existing account is not there anymore please help me. Its either I forgot my pass phrase or my trezor got reset

Hi @Langly1087 sorry, I just saw your message… Thanks for the help, I’ll join your discord channel and we can set up the call from there?

If you forgot your password, then no one can help you with that. This is why we recommend writing the passphrase and seed phrase down on a piece of paper as soon as you create it.

You’re likely using the wrong passphrase which is why you aren’t able to find your existing ronin accounts that the trezor is connected to. Keep trying all the passphrases you think you might have used. Maybe even misspell them to see if you accidentally did that.

You should also check that it was the standard wallet that you used by accident.


You’re missing accounts are likely in a hidden wallet you accidentally created.

Try accessing a wallet by using your pin number. That’s a common mistake for people new to the Trezor wallet and has be a solution for a few people I have helped.