Icannot connect to my ronin wallets

Have you tried the suggestions to others in this forum thread (above here)? Some of the posts seem to be similar to your issue.

Yes sir i have almost everything. Im curious to trying one thing though, what if i wipe out existing seedphrase and reset??

My friend, have you fixed ur issue?

Sure, you can try that but I don’t think it’ll change anything. Ronin wallets with Trezor is a minefield of possible problems, which the volum of support requests here, in the Trezor forums, shows. Frankly, it’s more likely that the issue is with Ronin than with Trezor.

However, if you do wipe and Recover your device, please make sure you have your private seed and any passphrase (if used) written down on beforehand. You should also do a Dry run Recovery first, to be sure you can do a real recovery later.

My friend,
I tried to recover my phrases in a second trezor luckily i have a spare. but still the issue is there, next i tried to wipe everything in the current trezor and still issue is there. i guess the issue is really with the Ronin wallet now. i dont know what to do anymore i tried everything. all my scholarship accounts are basically dead now. ughhh ronin/axie support not even responding. theres basically no way of fixing this anymore i guess? idk… im lost damn…

Don’t give up yet. Maybe someone else have tips you can try. @Langly1087, for instance. He’s the best authority on Ronin of our users. Or try Ronin support.

One thing I thought of now - are you sure you use the Ronin bridge from Metmask? Appearently this is important for Ronin accounts to work with Trezor.

Also watch these two videos, if you haven’t already:

ive just watched the video and now, theres only one thing i didnt do as @Langly1087 mentioned on his video and that is that my metamask is not connected to trezor. i only connected trezor to my ronin. meaning to say, when i created the account on the axie marketplace, the metamask that is synced is not “trezor connected” but it still pushed through. im not sure if this has an effect but will try to desync the existing metamask and create a new one then sync again. will update in a bit

Hi there,
Just to update i have done the proper creation of accounts, ronin connected to trezor, but the metamask wasnt connected so i unsynced the current metamask that wasnt connected to trezor and made a new metamask address and connected to trezor and here comes the problem, everytime i confirm on ronin to sync, nothing happens. literally it goes just back. so nothing is fixed.

here’s an example video of what im experiencing:

this video is from @Troy from another forum here and it seems he never got to fix this issue. he can neither log in with ronin nor gift the axies.

im not sure what else is there to do now…

heres the link to @Troy post:

Update: i tried to import my ronin wallet to mozilla since i first set them up on chome. and now, im creating new ronin accounts connected to trezor hardware, heres the problem: NONE of my existing scholar addresses are to be found from the 50 ronin trezor address choices… i think this is where the problem could possibly be? note also that when i set up the trezor the first time. i had the generic seed phrases, then i wiped it all off and created a new seedphrase which is what i have now. could this be an issue? im not so sure as to before i sent my scholar axies from normal ronin to the newly created ronin trezor… i tested to send SLP’s to trezor, then out from trezor ronin to normal ronin and it worked just fine. im really out of ideas now.

If someone ever occurs this same problem and gets to fix it please let me know somehow here :frowning: i guess this is the end of the line for all my scholars…

Yes, that could be the issue, if you created your Trezor connected Ronin account with the first seed. A new seed will generate different addresses.

But note that Trezor seed and passphrase is one thing, Ronin seed and passphrase is another. The latter only applies to native Ronin accounts.

@GreenCross no, it didn’t fix at all. I habe all my assets there. I don’t know ehat really happened. I cannot connect to ronin to MP. I wipe already, nothing change.

Hi everyone,

To all that have read this thread, i have found the solution to my problem and others who may be experiencing it. Its exactly as ive tagged on my post above as @Troy .

The issue is complicated but the answer is simple:

Answer: Please make sure you type in your Passphrase correctly. Thats that… ive been stressing out for 3 days only to find out my passphrase for example “Password123” is supposedly “Password12345”

Hope this helps out.


Glad to hear you found out what the problem was! :slight_smile:

1 Like

If only people would accept that they are typing in the password mistakenly…


Trezor was successfully installed on my windows10. Just finished the setup and now creating a ronin trezor account. Few mins successfully created trezor account BUT IT HAS NO HARDWARE SIGN ON THE SIDE. What to do?

Tried it again for the second time but still no hardware logo on the side…

Hi @Meoncrypto,

Take a look at this post and see if the two videos linked there can help.

1 Like

You might have gotten your answer already, but Sky Mavis did a design and coding update on the Ronin wallet. The blue bubble no longer shows, and you no longer have to create a ronin-sub account in order to connect the hardware wallet.

You can now connect the hardware wallet without a subaccount created. Once you do that, you will see the “Trezor 1” subaccount connected to the Ronin Wallet. If you click on that, you’ll be able to see the blue hardware bubble that you are looking for.

1 Like


I bought a Trezor wallet a month ago to provide extra protection to my Ronin wallet.

I’ve never connected my Trezor wallet to my Ronin, and when I clicked on the Ronin’s extension, there’s no connection also to any hardware wallet (In this case, Trezor).

But whenever I tried to connect, I couldn’t find the Ronin accounts that I want.

Is there something that I did wrong or any resolution for this?

Thanks a lot!

Hello @nel,

Take a look at this post and see if the two videos linked there can help.

Hi @Petosiris , many thanks for your reply!

I did watch those videos actually before posting this thread. In the video, when he connects the Trezor with Metamask and Ronin, he has everything listed there.

Meanwhile, on my side, I’ve never connected my Trezor, but when I tried to connect, I can’t seem to find my corrent Ronin (or even Metamask - according to that video).

Not sure what’s the fix since it’s been 1 month I’ve been trying.

You have to create a new Ronin account paired with your Trezor. See here.

Note that how to use Ronin is outside the scope of this forum. However, there are many posts and some solutions here, if you want to search for an answer. Otherwise I’d advice you to contact Ronin support.