Icannot connect to my ronin wallets


support no read me :pensive:

@1112,

This is probably a Ronin issue. If you’ve tried everything suggested by @pavel above and @MichalZ here and here and it didn’t work, then please contact Ronin support.

If that doesn’t work either then we’ll try to help you but, frankly, you should probably let a friend or family member who knows english better help you write messages here, because what you write doesn’t make much sense - to me anyway.

sorry could u plz clarify on this.

So when you click in ronin, add hardware wallet, select trezor. Then a list of wallet addresses pop up.

So i select the ETH address located from my trezor yes?

Then ronin wallet will create a ronin: to replace the 0x for that same address. This is correct yes?

Repeat the step for metamaks, but metamask will retain the original 0x of the trezor eth address.

So at this point you can safely send WETH, SLP and AXS to the ronin wallet setup for the trezor right?

My last question is, what about buying axies on the marketplace using that trezor ronin wallet. Can it buy, store and play axies on this ronin wallet?

Hey buddy! Sorry for the slow reply! It’s currently being edited. Hope to have it on youtube in the next day or two. I’ll post it here when it’s done. Or you can subscribe to my youtube.
All my Social links >> @langly1087 | Linktree

Hi Im having issue same as you… I hope you could help me as well. Im not familiar with the words Ad blocker. Is there a YOutube video you can recommend?? PLEASE I NEED Help Guys!

Hi @Vash29,

Here are two videos you should see:

Please help me. I can’t connect ronin to marketplace using my trezor. All my asset are already there. Please help me. Thank you in advance

i got the same problem…i transfer 3 axie on the ronin address provided by the trezor…here’s some of my screenshots









Hello what shall you do to resolve the problem

Have you tried everything Pavel and MichalZ suggested in this thread?
Also, as I remember @Langly1087 said in his video that it’s important to use the Ronin Bridge when connecting to Ronin from Metamask. You could also try to contact Ronin support or Axie Infinity Discord if you’re stuck.

Yes I already tried it and yet still same scenario. I can’t logged in to my ronin but the trezor is connected

Are you able to log-in with a normal Ronin wallet axie infinity account?
Also, have you tried creating a new ronin trezor account and logging in with that?

If you’re able to do the two above things, then the issue would be isolated to some kind of bug with the Ronin Wallet.

Hey there,

im a positive on both choices given, although the issue is still there. its really frustrating as im a manager and cant pay my scholars. any solutions for this please?

1 Like

Hi @GreenCross,

Please see this post and try that.

Hi @Petosiris,

When i created the ronin trezor accounts for my scholars, the metamask wallets synced to them i did not connect to trezor. in other words, ronin connected to trezor while the metamask connected to ronin is not connected to trezor. also i had passphrases and now i disabled it, it still doesnt work as well as placing it back On again.

Any thoughts on this?

Also i’ve tried again today hoping its just a lockdown of the account 24 hours but still not working :frowning: ughhh… i cant even contact the Ronin wallet support. theres no way contacting them

Have you tried the suggestions to others in this forum thread (above here)? Some of the posts seem to be similar to your issue.

Yes sir i have almost everything. Im curious to trying one thing though, what if i wipe out existing seedphrase and reset??

My friend, have you fixed ur issue?

Sure, you can try that but I don’t think it’ll change anything. Ronin wallets with Trezor is a minefield of possible problems, which the volum of support requests here, in the Trezor forums, shows. Frankly, it’s more likely that the issue is with Ronin than with Trezor.

However, if you do wipe and Recover your device, please make sure you have your private seed and any passphrase (if used) written down on beforehand. You should also do a Dry run Recovery first, to be sure you can do a real recovery later.