I need help! I cannot send anything from my etherium wallet

My Trezor wallet works just fine for my bitcoin and other ERC20 tokens. However, when I try to send ETH from my ETH wallet, the transactions never process. I have bumped up my gas fee to process the transaction but nothing happens. I tried moving some ETH from one ETH wallet on Trezor to another and that didn’t work. I tried sending ETH to my Ledger and even back to my coinbase exchange and either of those didn’t work. Now I simply can’t move the ETH. I don’t know what to do next and really need some help from the community.

Hi @michaelh,

When sending funds from your Trezor you’re supposed to get a couple of confirmation prompts on your Trezor device – one for the fee amount and one for the transaction itself. As you already know, you need enough ETH in your wallet to cover the transaction fee too. If anything is wrong you should get an error message instead. But nothing shouldn’t happen.

Have you looked up your transaction on https://etherscan.io/ and see if you can find it in a pending or canceled state. Or in any state?

It could be that Tor doesn’t work properly, if you use it. If so, try to disable the Tor network before retrying the transaction again. Click on the ontion icon on top right in Trezor Suite.

Please also check that you’re using the latest versions of Firmware and Trezor Suite desktop (or Trezor Bridge, if you’re using the web version of Trezor Suite). You can check your Bridge status on Note that you don’t need to run Trezor Bridge if you use the desktop version of Trezor Suite, since Bridge is built into it.

You may also try to reinstall Trezor Suite.

Edit: if you use an Incognito window/tab in your browser, try to use a normal non-incognito window.

Thank you so much for that information. I will look at the etherscan to find what state the pending transaction was in but I had enough ETH in my wallet to cover the transaction fee and even boosted the gas fee to see if that would push the transaction through. I don’t use Tor or an incognito window and the firmware has been updated. I guess I may need to reinstall the Trezor suite. The dashboard shows that my ETH is in the wallet which I guess is a good thing but I still can’t send or receive with the wallet.