I lost all my crypto becasue of a TREZOR mistake - NEED HELP PLEASE

Here’s what happened:

  1. I made two USDC transactions trough the eth network. The first one was made with a very low gas fee (11 gwei). So now they’re both stuck.

  2. After that I tried to bump the fee on Trezor, but it says I don’t have enough funds. I actually do, but it seems this is a common Trezor bug.

  3. So after that, I read though the forums and tried using metamask to make a new transaction with the same NONCE as the first one with much higher gas fees, so the first transaction would be replaced. The problem is that’s not working, I tried like 30 times with many differrent GAS inputs, and none have worked, here is the error message:

Transaction failed! [ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32000,”message”:”replacement transaction underpriced”}}’

  1. I tried reseting a bunch of times, also tried metamask on 3 different browers.

  2. Then I found out that no matter the inputs I set to gas fees, the transaction always come out with 0 gas fees in the “total gas fee” and " max fees per gas". Somehow it always come out with the Gas Limit of “50000”, which is the valeu that I set on my first try at metamask and it never changes.

  3. So long story short, all my crypto is in the eth netwrok on trezor, so if I don’t figure this out I will lose all of it. I’m desperate guys, I’d really appreciate some help here.

it’s not a bug, if you have multiple stuck transactions the bump fee will not work

You did not loose anything, as you are saying your coins are on the network and you need to cancel transaction.
The error is clear, low gas. Set it really high, only the gas that will actually be needed will be consumed for the fee, not everything you set.
Also, remember always to cancel the oldest stuck tranasction.

It’d be nice if Trezor Suite informed users about this, maybe a dialog information during the bump operation or in a help text.