How do I import a wallet to my Trezor Model One?

Is it possible to import a BTC/LTC wallet to my Trezor Model One? If so, how do I do this?

Hi @Nmin,

Please tell us more about what you want to do.
Is your wallet in an online exchange wallet, like CoinBase or Binance?

Basically, you don’t “import” a wallet or an account to your Trezor, you generate a Receive address in your Trezor account and then Send/withdraw the funds there from the current account. Note that BTC and LTC are two different coins and need to be sent to two differents accounts in your Trezor.


Send current wallet BTC account, 0.1 BTC → Trezor wallet BTC account’s Receive address
Send current wallet LTC account, 2 LTC → Trezor wallet LTC account’s Receive address

See how to receive crypto:

1 Like

Hi Petosiris.

Thanks for your response.

I have been using my Trezor wallet to receive funds from an app-based wallet. But for some reason, Bitcoin transactions have stopped going through from the app wallet. When I entered the transaction hash into Bitcoin info sites I get the response “No transaction found” so it seems the transactions are not being sent from the app.

I have contacted the app’s customer service team, but they just say their dev team is working on the issue and I’ll have to be patient - this has been the case for more than 24 hours. My patience is running thin.

They suggested importing the wallet into another wallet, so this is what I would like to do - ideally directly into my Trezor device. I have the seed phrase. But I’m not sure if this is possible.

First of all: do not use your seed from “the app” to “import” anything to Trezor, or vice versa. Hold your Trezor seed and your other seed separate, never copy or mix them. If you use your Trezor Recovery seed in your app, then you simply give away your Trezor wallet to anyone who may control your app’s wallet.

As I understand you, you set up your Trezor to receive BTC from your BTC app’s account. I don’t know what app you use or why the transactions stopped, but it’s probably an issue with the app or its site/owners. If it worked before then it should work now. It has nothing to do with Trezor as far as I can see with the info you provide.

I don’t know what the app support people meant by “importing” your wallet into another wallet. The correct term is Send coins from your wallet’s account to another wallet’s account Receive address. By using a term like “importing” they only confuse users to think there’s another, maybe faster or easier, way to do this with the seed. This is wrong and dangerous and you will probably lose your funds if you go that route.

Learn about seed:

I’m definitely not using my Trezor seed in the app!

Actually the problem is now suddenly and unexpectedly solved - I have imported the app wallet into another device that does not have any other wallets set up on it, so I will be able to send my BTC from that device. It’s probably a good thing not to have all my funds in the same place.

Thanks again.

1 Like

Well, if your situation is resolved then I wish you luck with your new solution, although the “import” thing still sounds like something you don’t want to do. But since you don’t say what you did I just hope it didn’t involve sharing any seeds between wallets.

I’d advice you to read as much as you can about basic crypto operations and Trezor functionality. It’s important to never do anything unless you’re sure what you do, otherwise you can risk losing funds.

In addition to this forum there’s a Learn section with knowledge base for Trezor users:

A blog, with many expert articles about common issues:

If you need to contact offcial Support, there’s a green Chat button in the bottom right corner on the Learn page. It leads you through a series of questions from a Chat bot, and if you don’t find your answer you may ask for manual support by issuing a Support Ticket. You can also click the Support link at the top of the forum page here.

1 Like