Help! Trezor not connecting to Wallet so I can Reset it

Hi Guys n Gals HeLp pleez
My Trezor T Arrived today…Yay
The USB chord was temperamental …boo
I downloaded the firmware and plugged in my Trezor T
I proceeded to set it up
I got my first “seed” word Fine, and then, my chord disconnected… booo

I unplugged and replugged my trezor with a stable usb chord

a Message displayed on my Trezor T

“Backup Failed”
Trezor logo
My Trezor"

YouTube told me to plugin and swipe to reset my trezor
I touch the green tick to proceed

My trezor didnt connect with the Wallet or firmware like on Youtube

On the Trezor display it read

Bootloader 2.0.3
By Satoshi Labs

All i can do there is download the firmware

Hi @chonk,

You can try this - Wipe your device and do a Factory Reset. Then setup your Trezor from the start. See this thread for more info.

1 Like

Cheers Petosiris
That was the screen I was Hoping to see but my Trezor doesnt seem to be connecting to the wallet.

  1. I get a graphic telling me to connect my trezor
  2. I can click on a link taking me to


I have the same problem, did you manage to reset the trezor?

Hi, @mel,

If it doesn’t work with the website option to do a Factory Reset, then try to Wipe Memory from Trezor Suite. See my message above and click the link, look at the last few posts in that linked forum thread.

This also applies to @chonk, if he haven’t solved his issue already.

Mine turned out to be then faulty usb cable they sent, my usb C was faulty and had another that worked. so it ended up an easy fix. hope yours is an easy fix @mel.


Thanks, i managed to do a factory reset.

1 Like

on what computer system?