Help stuck at: Trezor Bootloader 1.10.0

My Trezor is stuck at Bootloader 1.10.0

I have tried 3 computers but its always the same.

I cant do anything.

Anyone know what i can do ?

Thanks for any help.

I did solve the problem.

hi, Thank you for an update.
I am glad that your issue has been resolved. Feel free to share with other users your experience about how you solved the problem.
If not this topic will be deleted in few days :wink:

What i did was i went to wallet.trezor.io and formated the Trezor ( deleted everything on my Trezor and made a new seed)

1 Like

hi
how did you solve it? i have the same problem
xaver

I suggest you to do the same thing:
as long as you have valid recovery seed go to wallet.trezor.io a proceed to factory reset, then recover your wallet.

Hi. Brand new user here. When I connected the Trezor One in Trezor Suite, it tried to update the firmware but did NOT EVER give my recovery seed phrase. So I aborted the firmware update on the Trezor. Now it’s stuck in bootloader and I still do NOT have my recovery seed.

What do I do?? It’s totally empty, can I do a factory reset?

Hi @WhiteSox05,

I believe you’ll find your answer here:

1 Like

Thank you! All set now!